View Issue Details

IDProjectCategoryView StatusLast Update
0002321FreeCADBugpublic2015-12-15 13:15
ReporterFat-ZerAssigned Towmayer 
PriorityurgentSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.16 
Summary0002321: Build failure on current (71be79e) master
DescriptionThere is a build failure when building without FREECAD_USE_PCL obviously caused by 212e2bf.
Additional InformationThe snipp of build message:
[ 73%] Building CXX object src/Mod/ReverseEngineering/App/CMakeFiles/ReverseEngineering.dir/BSplineFitting.cpp.o
cd /tmp/FreeCAD_trunk-build/src/Mod/ReverseEngineering/App && /usr/bin/c++ -DHAVE_CONFIG_H -DHAVE_LIMITS_H -DQT_CORE_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_OPENGL_LIB -DQT_SVG_LIB -DQT_UITOOLS_LIB -DQT_WEBKIT_LIB -DQT_XML_LIB -DReverseEngineering_EXPORTS -D_OCC64 -Wall -Wno-deprecated -Wno-write-strings -D_OCC64 -g -DFC_DEBUG -fPIC -I/tmp/FreeCAD_trunk-build -isystem /usr/include/qt4 -isystem /usr/include/qt4/QtOpenGL -isystem /usr/include/qt4/QtSvg -isystem /usr/include/qt4/QtUiTools -isystem /usr/include/qt4/QtWebKit -isystem /usr/include/qt4/QtGui -isystem /usr/include/qt4/QtXml -isystem /usr/include/qt4/QtNetwork -isystem /usr/include/qt4/QtCore -I/tmp/FreeCAD_trunk-build/src -I/home/alexander/projects/free-cad_code/src -I/usr/lib64/opencascade-6.8.0/ros/lin/inc -I/usr/include/python2.7 -I/usr/include/eigen3 -o CMakeFiles/ReverseEngineering.dir/BSplineFitting.cpp.o -c /home/alexander/projects/free-cad_code/src/Mod/ReverseEngineering/App/BSplineFitting.cpp
/home/alexander/projects/free-cad_code/src/Mod/ReverseEngineering/App/BSplineFitting.cpp:101:24: error: missing binary operator before token "("
 #if PCL_VERSION_COMPARE(>=,1,7,0)

The status of bug is high due to it's a build-time issue. Please fix at as soon as possible.
TagsNo tags attached.

Activities

Fat-Zer

2015-11-01 05:46

reporter   ~0006512

Adding -DFREECAD_USE_PCL=ON results in another build failure:

[ 73%] Building CXX object src/Mod/ReverseEngineering/App/CMakeFiles/ReverseEngineering.dir/BSplineFitting.cpp.o
cd /tmp/FreeCAD_trunk-build/src/Mod/ReverseEngineering/App && /usr/bin/c++ -DDISABLE_OPENNI -DDISABLE_OPENNI2 -DDISABLE_PCAP -DDISABLE_PNG -DHAVE_CONFIG_H -DHAVE_LIMITS_H -DHAVE_PCL_SURFACE -DQT_CORE_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_OPENGL_LIB -DQT_SVG_LIB -DQT_UITOOLS_LIB -DQT_WEBKIT_LIB -DQT_XML_LIB -DReverseEngineering_EXPORTS -D_OCC64 -DvtkRenderingCore_AUTOINIT="3(vtkInteractionStyle,vtkRenderingFreeType,vtkRenderingOpenGL)" -Wall -Wno-deprecated -Wno-write-strings -Wno-deprecated -D_OCC64 -g -DFC_DEBUG -fPIC -I/tmp/FreeCAD_trunk-build -I/usr/include/vtk-6.1 -I/usr/include/jsoncpp -I/usr/include/libxml2 -I/usr/include/freetype2 -isystem /usr/include/qt4 -isystem /usr/include/qt4/QtOpenGL -isystem /usr/include/qt4/QtSvg -isystem /usr/include/qt4/QtUiTools -isystem /usr/include/qt4/QtWebKit -isystem /usr/include/qt4/QtGui -isystem /usr/include/qt4/QtXml -isystem /usr/include/qt4/QtNetwork -isystem /usr/include/qt4/QtCore -I/tmp/FreeCAD_trunk-build/src -I/home/alexander/projects/free-cad_code/src -I/usr/lib64/opencascade-6.8.0/ros/lin/inc -I/usr/include/python2.7 -I/usr/include/eigen3 -I/usr/include/pcl-1.7 -o CMakeFiles/ReverseEngineering.dir/BSplineFitting.cpp.o -c /home/alexander/projects/free-cad_code/src/Mod/ReverseEngineering/App/BSplineFitting.cpp
/home/alexander/projects/free-cad_code/src/Mod/ReverseEngineering/App/BSplineFitting.cpp:44:55: fatal error: pcl/surface/on_nurbs/fitting_surface_tdm.h: No such file or directory
 # include <pcl/surface/on_nurbs/fitting_surface_tdm.h>
                                                       ^

sci-libs/pcl-1.7.2 on gentoo doesn't provides that file nor directory "on_nurbs" at all...

Related Changesets

FreeCAD: master caec2d98

2015-11-01 18:07:56

wmayer

Details Diff
+ fixes 0002321: Build failure on current (71be79e) master Affected Issues
0002321
mod - src/Mod/ReverseEngineering/App/BSplineFitting.cpp Diff File
mod - src/Mod/ReverseEngineering/App/BSplineFitting.h Diff File

Issue History

Date Modified Username Field Change
2015-11-01 05:29 Fat-Zer New Issue
2015-11-01 05:46 Fat-Zer Note Added: 0006512
2015-11-01 17:08 wmayer Changeset attached => FreeCAD Master master caec2d98
2015-11-01 17:08 wmayer Assigned To => wmayer
2015-11-01 17:08 wmayer Status new => closed
2015-11-01 17:08 wmayer Resolution open => fixed
2015-12-15 13:15 yorik Fixed in Version => 0.16