View Issue Details

IDProjectCategoryView StatusLast Update
0002315FreeCADBugpublic2015-12-09 12:56
ReporterjmaustpcAssigned Toabdullah 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platform64 bitOSKubuntuOS Version14.04
Product Version0.16 
Target Version0.16Fixed in Version0.16 
Summary0002315: Mirror Sketch - error pops up "can't find property"
DescriptionMirror sketch, produces an empty new sketch and a pop up error message "can't find property"


OS: Ubuntu 14.04.3 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.5841 (Git)
Build type: Release
Branch: master
Hash: e7d16c5f620bc4ddded8b8eae97d6e29c0012490
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
Steps To ReproduceCreate a new document, new sketch on default plane xy, sketch an "L" or any other shape, constrain or don't makes not difference, close sketch edit mode, then select mirror sketch. An error box pops up saying "can't find property" and a new empty sketch is created.

Help forum post where this was discovered
http://forum.freecadweb.org/viewtopic.php?f=3&t=13015#p104260
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

FreeCAD: master 501fa80e

2015-12-04 14:49:40

abdullah


Committer: wmayer Details Diff
Sketcher: Fix Sketch Mirror functionality

=========================================

The problem:
Mirror stopped working.

How to reproduce:
Select a sketch, and apply "Mirror Sketch" from the menu.

Why?
With the introduction of expressions, mirror sketch stopped working. The reason is that mirror functionality did use the "clone" function to make copies of constraints
and then modify their values. After expessions introduction, which introduces a unique tag per constraint, this copy was regarded as a "rename" of the original constraint
as they shared the unique tag.

Fix?
New function "copy()" for a constraint, that copies all the content but the tag.
Affected Issues
0002315
mod - src/Mod/Sketcher/App/Constraint.cpp Diff File
mod - src/Mod/Sketcher/App/Constraint.h Diff File
mod - src/Mod/Sketcher/App/SketchObject.cpp Diff File

Issue History

Date Modified Username Field Change
2015-10-29 15:14 jmaustpc New Issue
2015-10-29 15:14 jmaustpc Status new => assigned
2015-10-29 15:14 jmaustpc Assigned To => abdullah
2015-12-09 12:56 wmayer Changeset attached => FreeCAD Master master 501fa80e
2015-12-09 12:56 wmayer Status assigned => closed
2015-12-09 12:56 wmayer Resolution open => fixed
2015-12-09 12:56 wmayer Fixed in Version => 0.16