View Issue Details

IDProjectCategoryView StatusLast Update
0002309PartDesignBugpublic2018-02-21 14:38
Reporterlaurent.despeyrouxAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSDebianOS Version8.2
Product Version 
Target Version0.17Fixed in Version0.17 
Summary0002309: PartDesign Fillet fail without warning when too many faces are selected
DescriptionWhen too many faces are selected, "PartDesign/Fillet" fail without warning. a message is visible in the console.

initial object :
https://www.laurent-despeyroux-conseil.fr/initial-step.FCStd (self signed certificate : your browser should rise an alarm)
goal (but the fillet is created in 3 step) :
https://www.laurent-despeyroux-conseil.fr/wanted-result.FCStd

The Fillet object is created in the treeview but nothing is really done. The console show an error :
<unknown exception traceback><type 'exceptions.SyntaxError'>: ('unexpected EOF while parsing', ('<string>', 1, 4057, 'App.activeDocument().Fillet.Base = (App.ActiveDocument.Cut003,["Edge569","Edge658","Edge232","Edge558","Edge275","Edge656","Edge230","Edge657","Edge277","Edge279","Edge654","Edge228","Edge655","Edge281","Edge652","Edge226","Edge653","Edge283","Edge650","Edge224","Edge651","Edge648","Edge222","Edge649","Edge285","Edge646","Edge220","Edge647","Edge287","Edge289","Edge644","Edge218","Edge645","Edge27","Edge216","Edge252","Edge253","Edge3","Edge31","Edge255","Edge291","Edge292","Edge328","Edge659","Edge257","Edge660","Edge661","Edge259","Edge662","Edge326","Edge663","Edge261","Edge664","Edge324","Edge322","Edge665","Edge263","Edge666","Edge320","Edge667","Edge265","Edge668","Edge318","Edge669","Edge267","Edge670","Edge671","Edge269","Edge672","Edge316","Edge673","Edge271","Edge556","Edge314","Edge688","Edge310","Edge554","Edge353","Edge686","Edge308","Edge687","Edge355","Edge357","Edge684","Edge306","Edge685","Edge359","Edge682","Edge304","Edge683","Edge361","Edge680","Edge302","Edge681","Edge678","Edge300","Edge679","Edge363","Edge676","Edge298","Edge677","Edge365","Edge367","Edge674","Edge296","Edge675","Edge35","Edge294","Edge330","Edge331","Edge23","Edge177","Edge213","Edge214","Edge250","Edge629","Edge179","Edge630","Edge631","Edge181","Edge632","Edge248","Edge633","Edge183","Edge634","Edge246","Edge244","Edge635","Edge185","Edge636","Edge242","Edge637","Edge187","Edge638","Edge240","Edge639","Edge189","Edge640","Edge641","Edge191","Edge642","Edge238","Edge643","Edge193","Edge560","Edge236","Edge628","Edge154","Edge562","Edge197","Edge626","Edge152","Edge627","Edge199","Edge201","Edge624","Edge150","Edge625","Edge203","Edge622","Edge148","Edge623","Edge205","Edge620","Edge146","Edge621","Edge618","Edge144","Edge619","Edge207","Edge616","Edge142","Edge617","Edge209","Edge211","Edge614","Edge140","Edge615","Edge19","Edge138","Edge174","Edge175","Edge613","Edge115","Edge564","Edge158","Edge611","Edge113","Edge612","Edge160","Edge162","


Steps To Reproduce- download https://www.laurent-despeyroux-conseil.fr/initial-step.FCStd (self signed certificate : your browser should rise an alarm)
- open it in FreeCAD
- select all the squared faces and the 2 cylindrical ones
- try to make a Fillet on them
- look to the console and read the error!
Additional InformationOS: Debian GNU/Linux 8.2 (jessie)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.5234 (Git)
Build type: Release
Branch: master
Hash: 3241b1ece15403ef1e2576990e456d48d9551be1
Python version: 2.7.9
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.7.0
TagsOCC 7.1, OCC Bug, upstream

Relationships

has duplicate 0002227 closedabdullah Fillet silently fails on face with too many edges 

Activities

Kunda1

2017-01-28 11:01

administrator   ~0008040

Shared forum link with 0002227 https://forum.freecadweb.org/viewtopic.php?f=10&t=20257

Kunda1

2017-01-29 18:58

administrator   ~0008088

This may be fixed in OCC 7.1 added to https://forum.freecadweb.org/viewtopic.php?f=10&t=20264

normandc

2017-01-29 19:28

manager   ~0008089

Last edited: 2017-01-29 20:07

View 3 revisions

The error I'm getting in current master is not identical to 0002227.

There may be multiple issues here. The original poster says to select all square faces. Problem is that a row of them is split by the cylindrical surface seam. When PartDesign Fillet/Chamfer takes a face selection, it attempts to proceed on all the edges extracted from the selected face, which creates an error with the seam edge.

If I select all the faces as per the OP's instructions, after some recompute time I get an error dialog that says the resulting shape is invalid. There is no output in Python console nor Report view.

If I remove the square faces split by the seam edge from the selection, then the Fillet succeeds.

So, if we consider there are two issues here:
1) Operation fails without a warning: this is fixed in current master. A dialog window appears.
2) Operation fails because too many faces are selected: this is invalid, the real issue is an improper selection by the user.

OS: Ubuntu 14.04.5 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.9822 (Git)
Build type: None
Branch: master
Hash: 0df4af4ba5e6edce825af6ecf6d024c704292633
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

normandc

2017-01-29 19:31

manager  

initial-step_simple.FCStd (3,261,773 bytes)

normandc

2017-01-29 19:32

manager   ~0008090

I made a simple copy of the object (stripping it of its history) and saved in a new file to reduce its filesize and attach it here.

normandc

2017-01-29 19:38

manager   ~0008091

There is still an issue: when trying to fillet the square faces split by the seam by selecting their edges rather than the face itself, it should succeed, but an error "Resulting shape is invalid" is thrown out.

IMO this an upstream issue related to OCC.

Kunda1

2017-03-16 12:20

administrator   ~0008640

@normandc when you have a moment can you test on 7.1?

Kunda1

2017-12-01 00:59

administrator   ~0010504

@wmayer can you test on OCC 7.1 or higher ?

Kunda1

2018-01-18 13:28

administrator   ~0010785

@wmayer ping

wmayer

2018-01-30 16:34

administrator   ~0010900

Last edited: 2018-01-30 16:35

View 3 revisions

The issue with too many edges was fixed a long time ago with:
https://github.com/FreeCAD/FreeCAD/commit/3c269f4ccd5680867246c63ea415ccf327182e96#diff-0c786c62e4e06db5627463b64786060e

The problem was that the internal command string had a limit of 4024 characters. When a command had more the string was truncated and thus left an incorrect Python expression. In 0.17 there is no such limit any more.

The issue that the fillet operation fails doesn't seem to exist in OCCT 7.0 any more.

Issue History

Date Modified Username Field Change
2015-10-26 09:18 laurent.despeyroux New Issue
2017-01-27 14:37 Kunda1 Tag Attached: duplicate
2017-01-28 10:59 Kunda1 Relationship added related to 0002227
2017-01-28 11:01 Kunda1 Note Added: 0008040
2017-01-28 11:02 Kunda1 Tag Detached: duplicate
2017-01-29 18:57 Kunda1 Tag Attached: OCC 7.1
2017-01-29 18:57 Kunda1 Tag Attached: OCC Bug
2017-01-29 18:57 Kunda1 Tag Attached: upstream
2017-01-29 18:58 Kunda1 Note Added: 0008088
2017-01-29 19:28 normandc Note Added: 0008089
2017-01-29 19:31 normandc File Added: initial-step_simple.FCStd
2017-01-29 19:32 normandc Note Added: 0008090
2017-01-29 19:33 normandc Note Edited: 0008089 View Revisions
2017-01-29 19:38 normandc Note Added: 0008091
2017-01-29 20:07 normandc Note Edited: 0008089 View Revisions
2017-03-16 12:20 Kunda1 Note Added: 0008640
2017-12-01 00:59 Kunda1 Note Added: 0010504
2018-01-18 13:28 Kunda1 Note Added: 0010785
2018-01-18 14:35 Kunda1 Target Version => 0.17
2018-01-30 16:34 wmayer Assigned To => wmayer
2018-01-30 16:34 wmayer Status new => closed
2018-01-30 16:34 wmayer Resolution open => fixed
2018-01-30 16:34 wmayer Fixed in Version => 0.17
2018-01-30 16:34 wmayer Note Added: 0010900
2018-01-30 16:34 wmayer Note Edited: 0010900 View Revisions
2018-01-30 16:35 wmayer Note Edited: 0010900 View Revisions
2018-02-21 14:38 Kunda1 Relationship replaced has duplicate 0002227