View Issue Details

IDProjectCategoryView StatusLast Update
0002277SketcherBugpublic2015-09-28 10:43
ReportertriplusAssigned Toabdullah 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.16 
Summary0002277: Deleting sketcher geometry crashes FreeCAD
DescriptionDeleting sketcher geometry crashes FreeCAD
Steps To Reproduce1. Open the file Plate1.fcstd
2. edit sketch
3. select all elements
4. press Delete key

http://forum.freecadweb.org/viewtopic.php?f=3&t=12588#p100939

Additional Informationhttp://forum.freecadweb.org/viewtopic.php?f=10&t=12591
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

FreeCAD: master 56c29e27

2015-09-26 06:46:39

abdullah


Committer: wmayer Details Diff
Sketcher: Bug fix: Building Vertex Index on Restore

===================================================

The bug was introduced by myself here:
https://github.com/FreeCAD/FreeCAD/commit/47c0859c1b702b6c7d1dcf5922317c4f325f5d2e

[code]
void SketchObject::onDocumentRestored()
{
try {
- rebuildExternalGeometry();
+ if(Support.getValue()) {
+ validateExternalLinks();
+ rebuildExternalGeometry();
+ }
Constraints.acceptGeometry(getCompleteGeometry());
}
[/code]

The issue is that "rebuildExternalGeometry" calls "rebuildVertexIndex". So for any sketch not having external geometry, if you open it, select everything and hit del, you will have a crash because
I effectively removed the creation of the index in this dossier. You won't have one if you do anything rebuilding the index before hitting del, like creating geometry, though.
Affected Issues
0002277
mod - src/Mod/Sketcher/App/SketchObject.cpp Diff File

Issue History

Date Modified Username Field Change
2015-09-25 15:02 triplus New Issue
2015-09-26 02:44 abdullah Assigned To => abdullah
2015-09-26 02:44 abdullah Status new => assigned
2015-09-28 10:43 wmayer Changeset attached => FreeCAD Master master 56c29e27
2015-09-28 10:43 wmayer Status assigned => closed
2015-09-28 10:43 wmayer Resolution open => fixed
2015-09-28 10:43 wmayer Fixed in Version => 0.16