View Issue Details

IDProjectCategoryView StatusLast Update
0002235PartDesignBugpublic2017-06-16 01:48
ReporterthorAssigned Tokkremitzki 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version14.04.3
Product Version 
Target VersionFixed in Version 
Summary0002235: Cannot mirror mirrored object (within Part Design)
DescriptionAttempting to mirror an object that is the result of a prior mirror operation fails with: "No valid features in this document. Please create a subtractive or additive feature first".

I would understand if only the new half would be mirrored, it being the last feature ... perhaps the tool needs to become more flexible regarding the scope it works on.

Multitransform is no workaround, as attempting to do 2 mirrors, vertical and horizontal axis, will fail, claiming one feature would not intersect support.

This leaves the Part workbench mirror tool, which means awkward workbench back and forth and extra fusion steps.
Steps To Reproduce* Create rectangle sketch.
* Pad it.
* Select result, try to apply "create a mirrored feature".
TagsNo tags attached.

Relationships

related to 0002863 assignedickby Add Mirror body feature to PartDesign 
related to 0003006 closedkkremitzki PartDesign Mirrored features fail due to unexpected inversion 

Activities

bejant

2015-09-02 11:01

reporter   ~0006321

I don't think this is a bug.

=====
Attempting to mirror an object that is the result of a prior mirror operation fails with: "No valid features in this document. Please create a subtractive or additive feature first".
...
* Create rectangle sketch.
* Pad it.
* Select result, try to apply "create a mirrored feature".
=====

Yes, if we use Part Design > Mirror tool on a Pad when that Pad is the only 3D object in the FreeCAD document, the tool fails. However, this is the expected FreeCAD bahavior because Part Design WB > Mirror only works on Features and not the whole 3D object. In this unique instance, Pad is the entire 3D object.

thor

2015-09-02 11:46

reporter   ~0006324

Seen another way, the mirrored thing is the only feature. A feature that could be mirrored easily, when it touches the mirror plane, the new geometry thus having support.

That would be useful behavior. Faking availability only to produce an error dialog is not.

Note the other aspects of this issue:
* Multitransform doesn't work right in this case.
* There's no other mirror tool in the workbench that would fill the gap.
* Switching workspaces is annoying and the Part workbench mirror doesn't care about keeping it one part. Isn't the later at the core of why the Part Design workbench even exists?

bejant

2016-03-08 02:08

reporter   ~0006895

@thor, this should have been discussed in the forum first, so please continue the discussion here:
http://forum.freecadweb.org/viewtopic.php?f=3&t=14563

kkremitzki

2017-06-12 07:19

administrator   ~0009351

With FreeCAD Pull Request 818 this part will no longer be an issue:

Someone wrote

Multitransform is no workaround, as attempting to do 2 mirrors, vertical and horizontal axis, will fail, claiming one feature would not intersect support.


and so thus MultiTransform should meet users' needs, resolving this bug.

kkremitzki

2017-06-16 01:48

administrator   ~0009397

Fixed with FreeCAD Pull Request 816

Issue History

Date Modified Username Field Change
2015-09-01 11:43 thor New Issue
2015-09-02 11:01 bejant Note Added: 0006321
2015-09-02 11:46 thor Note Added: 0006324
2016-03-08 02:08 bejant Note Added: 0006895
2017-01-16 09:42 Kunda1 Relationship added related to 0002863
2017-05-02 11:28 Kunda1 Relationship added related to 0003006
2017-06-12 07:19 kkremitzki Note Added: 0009351
2017-06-16 01:48 kkremitzki Assigned To => kkremitzki
2017-06-16 01:48 kkremitzki Status new => closed
2017-06-16 01:48 kkremitzki Resolution open => fixed
2017-06-16 01:48 kkremitzki Note Added: 0009397