View Issue Details

IDProjectCategoryView StatusLast Update
0002232ArchBugpublic2015-09-10 21:09
ReporterGoofy03 Assigned Toyorik  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSArch linuxOS Version4.1.6-1-ARCH
Product Version0.15 
Target VersionFixed in Version0.16 
Summary0002232: Can't save windows
DescriptionOn my 0.14 file i have doors and windows on my house when i open it all have disappeared. I know i need to change a param (height) on all of them. But when i save it (in 0.15) and reopen file they have disappeared again …
TagsNo tags attached.
FreeCAD Information

Activities

yorik

2015-08-29 23:00

administrator   ~0006303

Can you please attach your file?

yorik

2015-09-10 19:36

administrator   ~0006392

This is *probably* (can't be sure without seeing the file) because of a bug in 0.14 which has been fixed in 0.15. Typing this code in the python console fixes the file:

import Draft
for o in FreeCAD.ActiveDocument.Objects:
    if Draft.getType(o) == "window":
        if hasattr(o,"SubVolume"):
            o.removeProperty("SubVolume")
            o.touch()
FreeCAD.ActiveDocument.recompute()

Goofy03

2015-09-10 19:40

reporter   ~0006394

Hi sorry it's solve since you help in other bug i submit same day … ;-)

yorik

2015-09-10 21:09

administrator   ~0006395

ok then! thanks for confirming

Issue History

Date Modified Username Field Change
2015-08-29 11:52 Goofy03 New Issue
2015-08-29 23:00 yorik Note Added: 0006303
2015-09-10 19:33 yorik Assigned To => yorik
2015-09-10 19:33 yorik Status new => feedback
2015-09-10 19:36 yorik Note Added: 0006392
2015-09-10 19:40 Goofy03 Note Added: 0006394
2015-09-10 19:40 Goofy03 Status feedback => assigned
2015-09-10 21:09 yorik Note Added: 0006395
2015-09-10 21:09 yorik Status assigned => closed
2015-09-10 21:09 yorik Resolution open => fixed
2015-09-10 21:09 yorik Fixed in Version => 0.16