View Issue Details

IDProjectCategoryView StatusLast Update
0002219FreeCADBugpublic2015-12-15 13:17
Reporterbhouston Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSWindows 10OS Version
Product Version0.15 
Target VersionFixed in Version0.16 
Summary0002219: Exporting to DAE from STEP import crashes on these files.
DescriptionIt is a simple crash during export.
Steps To ReproduceImport any of the following STEP files (though most STEP files work, I'm finding roughly 20% do not because of this crash):

https://www.dropbox.com/s/0k3jt9ee8p849pu/A320.STEP?dl=0
https://www.dropbox.com/s/wonwr3fwf6alram/Veyron.STEP?dl=0

Then try to export as a Collada/DAE.

It will crash.
Additional InformationFull stack trace:

Traceback (most recent call last):
  File "<string>", line 4, in <module>
  File "C:\Program Files\FreeCAD 0.15\Mod\Arch\importDAE.py", line 139, in export
    n = f.normalAt(0,0)
<class 'Part.OCCError'>: normal not defined
Stack Trace: Traceback (most recent call last):
  File "<string>", line 4, in <module>
  File "C:\Program Files\FreeCAD 0.15\Mod\Arch\importDAE.py", line 139, in export
    n = f.normalAt(0,0)

Traceback (most recent call last):
  File "<string>", line 4, in <module>
  File "C:\Program Files\FreeCAD 0.15\Mod\Arch\importDAE.py", line 139, in export
    n = f.normalAt(0,0)
<class 'Part.OCCError'>: normal not defined
Stack Trace: Traceback (most recent call last):
  File "<string>", line 4, in <module>
  File "C:\Program Files\FreeCAD 0.15\Mod\Arch\importDAE.py", line 139, in export
    n = f.normalAt(0,0)

TagsNo tags attached.
FreeCAD Information

Relationships

has duplicate 0002241 closedyorik Arch DAE export error 

Activities

yorik

2015-08-18 16:52

administrator   ~0006296

Hm never seen a face with normal not defined before... In any case should be an easy fix, but I'll have a look first as of why this happens

yorik

2015-08-28 20:49

administrator   ~0006301

Ok I didn't find the cause, but in any case used a more robust method now that should not produce that error anymore.
However these two files are very big, and will need a lot of memory to export. It is advisable to convert them to meshes simplifying them a lot before exporting..

Related Changesets

FreeCAD: master f70d5be2

2015-08-28 22:46:52

yorik

Details Diff
Arch: Fixed DAE export - fixes 0002219 Affected Issues
0002219
mod - src/Mod/Arch/importDAE.py Diff File

Issue History

Date Modified Username Field Change
2015-08-18 01:50 bhouston New Issue
2015-08-18 16:47 yorik Assigned To => yorik
2015-08-18 16:47 yorik Status new => assigned
2015-08-18 16:52 yorik Note Added: 0006296
2015-08-28 20:47 yorik Changeset attached => FreeCAD Master master f70d5be2
2015-08-28 20:47 yorik Status assigned => closed
2015-08-28 20:47 yorik Resolution open => fixed
2015-08-28 20:49 yorik Note Added: 0006301
2015-09-07 18:15 yorik Relationship added has duplicate 0002241
2015-12-15 13:17 yorik Fixed in Version => 0.16