View Issue Details

IDProjectCategoryView StatusLast Update
0002200FreeCADBugpublic2016-02-28 17:57
ReporterBlindleistungAssigned Towmayer 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindows7OS Versionx64
Product Version0.15 
Target VersionFixed in Version0.16 
Summary0002200: Application crash when modifying fillet
DescriptionApplication crashes when changed affected edges on a cut of two cylinders.

When doing a boolean-subtract to cut a thin cylinder through a bigger cylinder sideways, the round end of the cut becomes a set of 4 curved edges.

Making a fillet for this set of four works, removing some crashes the Application.
Steps To ReproduceSteps 1-5 already done in file attached. But also reproduces every time when clicking a new model.

1. Make Cylinder, 10mm tall, 2mm radius, move to 0/0/-5mm.
2. Make Cylinder, 10mm tall, 1mm radius, move to -5mm/0/0, rotate 90deg around (0/1/0)
 ( they should intersect at their centers now )
3. Create boolean-diff, subtracting the thin from the thick.
4. Select the four parts of edge on one end of the cut-through hole.
5. Add a fillet with 0.2mm radius.

(or load the file attached and start @ 6)

6. Double-click 'Fillet' in Hierarchy, deselect last of 4 edges in fillet.
7. Click OK. Nothing changes in object in view.
8. Double-click 'Fillet' in Hierarchy, deselect last of 3 edges in fillet.
9. Application crashes immediately when clicking on the check.
TagsNo tags attached.

Activities

Blindleistung

2015-07-25 12:54

reporter  

reproCrash.FCStd (Attachment missing)

yorik

2015-08-05 02:29

administrator   ~0006273

It doesn't crash for me with current master code... But the fillet indeed cannot be executed for several combinations of edges... I suppose this is a limitation of OpenCasCade, not sure we can do much about it...

wmayer

2016-02-28 16:21

administrator   ~0006853

I can confirm this crash. However, it happens when de-selecting the last of the four edges. It's caused by a recursive call of SelectionSingleton::rmvSelection() which corrupts the internal iterator variable.

Related Changesets

FreeCAD: master 4e29db90

2016-02-28 18:56:21

wmayer

Details Diff
+ fixes 0002200: Application crash when modifying fillet Affected Issues
0002200
mod - src/Mod/Part/Gui/DlgFilletEdges.cpp Diff File

Issue History

Date Modified Username Field Change
2015-07-25 12:54 Blindleistung New Issue
2015-07-25 12:54 Blindleistung File Added: reproCrash.FCStd
2015-08-05 02:29 yorik Note Added: 0006273
2016-02-28 16:21 wmayer Note Added: 0006853
2016-02-28 16:21 wmayer Assigned To => wmayer
2016-02-28 16:21 wmayer Status new => confirmed
2016-02-28 17:57 wmayer Changeset attached => FreeCAD Master master 4e29db90
2016-02-28 17:57 wmayer Status confirmed => closed
2016-02-28 17:57 wmayer Resolution open => fixed
2016-02-28 17:57 wmayer Fixed in Version => 0.16