View Issue Details

IDProjectCategoryView StatusLast Update
0002195Expressions[FreeCAD] Bugpublic2018-09-14 20:23
ReporterFat-ZerAssigned Toeivindkvedalen 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.16 
Target VersionFixed in Version[FreeCAD] 0.17 
Summary0002195: Input validator doesn't allow comma as decimal separator inside input fields a second time
DescriptionThere is a minor bug in input field validator. The comma as decimal separator (DS) is not allowed to show in an expression for the second time.
Steps To Reproduce1. Edit any input that allows expression e.g. a length sketch constraint.
2. Try to type in any expression with two decimals with comma DS e.g. "2,5+1,5"

The validator won't allow to type in the second comma.
Additional InformationI'm not sure if the locale should setup a comma DS to reproduce this.
The dot works fine in such cases.

Note: the bug was found by some german user from IRC who's nick I don't remember.
Tagsexpressions, locale, units

Relationships

related to 0002270 closed Sketcher Grid size cant be set below 0,2 mm 
related to 0002103 closed Arch Arch: Dimensions jumping by 10e3 on german localization 
related to 0002135 closed FreeCAD Units module is not properly considering the QLocale::groupSeparator() character 

Activities

wmayer

2015-09-15 08:57

administrator   ~0006424

Until Eivind's expression parser is not merged into master there will be nothing done on this. At the moment it's just luck that you can even enter e.g. "2,5+1" because the validator doesn't explicitly forbid it.

yorik

2016-02-12 16:14

administrator   ~0006827

I will remove the target version for now as there is nobody working on it.

Kunda1

2017-01-19 02:44

administrator   ~0007871

fixed summary typos

Kunda1

2017-10-10 02:23

administrator   ~0010278

@eivindkvedalen care to weigh in on this?

Kunda1

2017-12-13 15:28

administrator   ~0010600

@eivindkvedalen can I assign this to you?

wmayer

2018-09-14 20:23

administrator   ~0011746

An input field has an expression editor where complex expressions can be entered. There is no need that an input field should support complex expressions directly.

Issue History

Date Modified Username Field Change
2015-07-20 07:15 Fat-Zer New Issue
2015-09-15 08:57 wmayer Note Added: 0006424
2015-09-15 08:57 wmayer Status new => acknowledged
2015-09-19 17:09 wmayer Relationship added related to 0002270
2016-01-29 16:23 yorik Target Version => 0.16
2016-02-12 16:14 yorik Note Added: 0006827
2016-02-12 16:15 yorik Product Version => 0.16
2016-02-12 16:15 yorik Target Version 0.16 =>
2017-01-19 02:44 Kunda1 Note Added: 0007871
2017-01-19 02:44 Kunda1 Summary Input validator doesn't allowed comma as decimal separator inside input fiels on second time => Input validator doesn't allow comma as decimal separator inside input fields a second time
2017-02-15 12:20 Kunda1 Tag Attached: units
2017-02-15 12:20 Kunda1 Tag Attached: locale
2017-02-15 12:21 Kunda1 Status acknowledged => confirmed
2017-02-15 12:22 Kunda1 Relationship added related to 0002103
2017-05-02 11:09 Kunda1 Relationship added related to 0002135
2017-10-10 02:23 Kunda1 Note Added: 0010278
2017-10-10 02:24 Kunda1 Tag Attached: expressions
2017-12-13 15:28 Kunda1 Note Added: 0010600
2017-12-13 15:29 Kunda1 Project FreeCAD => Expressions
2018-09-14 20:23 wmayer Assigned To => eivindkvedalen
2018-09-14 20:23 wmayer Status confirmed => closed
2018-09-14 20:23 wmayer Resolution open => fixed
2018-09-14 20:23 wmayer Fixed in Version => 0.17
2018-09-14 20:23 wmayer Note Added: 0011746