View Issue Details

IDProjectCategoryView StatusLast Update
0002194SketcherFeaturepublic2018-12-20 12:56
ReporterabdullahAssigned Toabdullah 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version0.16 
Target Version0.18Fixed in Version0.18 
Summary0002194: Sketcher delete is very slow as the number of elements increase
DescriptionSketcher delete operates on each element at a time (it generates a delete python command for each geometry and constrain involved).

Deleting a "high" number of elements takes a lot of time.

Implementation via list instead should be considered.
Steps To ReproduceJust make a lot of geometries and constraints in the sketcher, select all of them and press "Del"....wait....wait....wait...
Tagsslow

Activities

abdullah

2018-12-19 16:00

manager   ~0012316

As a result of many other improvements, there is no longer the perception of deleting the geometry being slow. Don't fix what ain't broken.

Kunda1

2018-12-20 12:56

manager   ~0012326

Edited Target version to 0.18 since this ticket was technically closed before the 0.18 release

Issue History

Date Modified Username Field Change
2015-07-20 06:02 abdullah New Issue
2015-07-20 06:02 abdullah Status new => assigned
2015-07-20 06:02 abdullah Assigned To => abdullah
2017-05-08 05:01 Kunda1 Tag Attached: slow
2018-10-06 15:12 abdullah Target Version => 0.19
2018-12-19 16:00 abdullah Status assigned => closed
2018-12-19 16:00 abdullah Resolution open => won't fix
2018-12-19 16:00 abdullah Fixed in Version => 0.18
2018-12-19 16:00 abdullah Note Added: 0012316
2018-12-20 12:56 Kunda1 Target Version 0.19 => 0.18
2018-12-20 12:56 Kunda1 Note Added: 0012326