View Issue Details

IDProjectCategoryView StatusLast Update
0002187FreeCADBugpublic2019-03-06 11:28
Reporterfrwi5432Assigned ToChris_G 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platform64-bitOSWindowsOS Version7
Product Version0.15 
Target Version0.18Fixed in Version0.18 
Summary0002187: Sweep tool fails with Frenet=True on special Wire created from Section
DescriptionThe Sweep tool creates an ugly structure when using Frenet=True, while the result with Frenet=False is ok.
The attached macro creates with Draft.upgrade a special Wire from a Section which was built out of a Revolve and a Sweep.
Steps To ReproduceRun the macro once with Frenet=False and once with Frenet=True. This can be changed at the beginning of function create_geometries().
A t t e n t i o n : The calculation might take some minutes.
Additional InformationSee also http://forum.freecadweb.org/viewtopic.php?f=22&t=11705&p=94102#p94102
Tagssweep

Relationships

related to 0002509 confirmed Part Sweep using bezier curve bug 

Activities

frwi5432

2015-07-09 07:27

reporter  

Path0904.FCMacro (Attachment missing)

frwi5432

2015-07-09 08:03

reporter  

Path0904.jpg (Attachment missing)

frwi5432

2015-07-09 08:10

reporter   ~0006246

How can I delete here an attachment?

Kunda1

2017-01-28 13:23

administrator   ~0008054

Bumped forum thread: https://forum.freecadweb.org/viewtopic.php?f=22&t=11705&p=156568#p156568

Kunda1

2017-05-13 12:29

administrator   ~0008981

"Chris_G" wrote

Hi,
The red spiral, in the above picture, is made of 4 BsplineCurves of degree 1 :
Edge 1, with 1026 poles
Edge 2, with 1026 poles
Edge 3, with 2463 poles
Edge 4, with 1003 poles
If I try to pick a normal somewhere on the first edge, I get :
>>> elt.normalAt(600)
Traceback (most recent call last):
  File "<input>", line 1, in <module>
Part.OCCError: LProp_CLProps::Normal(...):Curvature is null or infinity

That should explain why Frenet mode is failing.
The solution is probably to discretize the faulty wire and recreate a clean BSplineCurve by interpoation or approximation.
But is it a FreeCAD bug ?
Maybe the Sweep tool should check the sweep path more strictly ?



Chrisg wrote

IMHO, but I am not a developer, this bug is valid.
The user doesn't even have an hint on what went wrong.
The user should, at least, be informed that the path is not valid for this sweep.

Kunda1

2017-05-13 12:29

administrator   ~0008982

@wmayer can you offer an opinion?

Kunda1

2017-07-03 21:20

administrator   ~0009661

@yorik ping

Kunda1

2017-08-23 11:58

administrator   ~0009997

@frwi5432 do you mind uploading the macro and image again?

frwi5432

2017-09-08 10:25

reporter   ~0010090

Hello,
attached you'll find the macro and the image.
Hope that helps.

Kind regards,
Willy

Path0904-2.FCMacro (9,212 bytes)
Path0904-2.jpg (55,724 bytes)
Path0904-2.jpg (55,724 bytes)

Kunda1

2018-03-03 10:43

administrator   ~0010988

Chris_G responded to the thread: https://forum.freecadweb.org/viewtopic.php?f=22&t=11705&start=10#p203254

UR_ responded as well: https://forum.freecadweb.org/viewtopic.php?f=22&t=11705&start=10#p204208

Chris_G wrote


Hi UR_,
I knew DeepSOIC's macro.
My question was more : "Why does OCC have this strange behaviour ?"
Even if I suppose that we probably cannot do anything anyway :(

Chris_G

2018-06-14 05:32

developer   ~0011431

I think this one can be closed.
Fixed by this PR :
https://github.com/FreeCAD/FreeCAD/pull/1507

Kunda1

2018-06-14 13:12

administrator   ~0011434

@Chris_G thanks! Sorry I can't attribute fix to you since you're not a developer per the tracker. I'll see what w can do about that

https://github.com/FreeCAD/FreeCAD/commit/be96fcc62d7b2f31996e491f4737ec5f8bc529ac
https://github.com/FreeCAD/FreeCAD/commit/f3ac51d9b7ca0ccca68879d31d69812fdebb7a9c

Issue History

Date Modified Username Field Change
2015-07-09 07:27 frwi5432 New Issue
2015-07-09 07:27 frwi5432 File Added: Path0904.FCMacro
2015-07-09 08:03 frwi5432 File Added: Path0904.jpg
2015-07-09 08:10 frwi5432 Note Added: 0006246
2017-01-19 13:11 Kunda1 Tag Attached: #pending
2017-01-28 13:23 Kunda1 Note Added: 0008054
2017-01-28 13:23 Kunda1 Status new => feedback
2017-01-28 13:23 Kunda1 Tag Attached: sweep
2017-02-17 13:47 Kunda1 Relationship added related to 0002509
2017-03-14 11:45 Kunda1 Priority high => normal
2017-03-14 11:45 Kunda1 Severity major => minor
2017-05-13 12:29 Kunda1 Note Added: 0008981
2017-05-13 12:29 Kunda1 Note Added: 0008982
2017-07-03 21:20 Kunda1 Note Added: 0009661
2017-08-23 11:58 Kunda1 Note Added: 0009997
2017-09-08 10:25 frwi5432 File Added: Path0904-2.FCMacro
2017-09-08 10:25 frwi5432 File Added: Path0904-2.jpg
2017-09-08 10:25 frwi5432 Note Added: 0010090
2017-09-08 10:25 frwi5432 Status feedback => new
2018-03-03 10:40 Kunda1 Target Version => 0.18
2018-03-03 10:43 Kunda1 Note Added: 0010988
2018-06-14 05:32 Chris_G Note Added: 0011431
2018-06-14 13:12 Kunda1 Status new => closed
2018-06-14 13:12 Kunda1 Resolution open => fixed
2018-06-14 13:12 Kunda1 Fixed in Version => 0.18
2018-06-14 13:12 Kunda1 Note Added: 0011434
2018-08-26 15:20 Kunda1 Tag Detached: #pending
2019-03-06 11:28 Kunda1 Assigned To => Chris_G