View Issue Details

IDProjectCategoryView StatusLast Update
0002161FreeCADBugpublic2015-06-17 14:04
Reporterquick61Assigned Toabdullah 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.16 
Summary0002161: 0.16.5111 External Geometry Bug
DescriptionIn Sketcher/PartDesign, using external geometry tool does not immediately show the external geometry edges and vertices. One must first create some geometry or close and reopen the sketch for the external geometry to show.
Steps To ReproduceMake a rectangle sketch and Pad.
Select a face and create new sketch.
Attempt to pick and edge or vertex as external geometry.
Additional InformationForum thread - http://forum.freecadweb.org/viewtopic.php?f=3&t=11386

OS: Kubuntu 14.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.5111 (Git)
Build type: Release
Branch: master
Hash: 238becaebb616db39e8836763fdbfc468a8a7fc5
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
TagsNo tags attached.

Activities

abdullah

2015-06-17 12:22

manager   ~0006208

Waiting for merge:
http://forum.freecadweb.org/viewtopic.php?f=17&t=11400

wmayer

2015-06-17 14:04

administrator   ~0006210

Merged.

Related Changesets

FreeCAD: master 074d5d7f

2015-06-17 13:57:02

abdullah


Committer: wmayer Details Diff
Sketcher: Bug fix External geometry not appearing upon insertion

================================================================

A last moment change to regulate redrawing introduced this issue (reducing the redrawing to the cases where the solver geometry and the sketchObject geometry are equal).
This change also solved other issues.

The case of adding external geometry is special because the DoF is the same after insertion, yet there is an insertion (as opposed to the toggle case, where there is a change but no insertion).

SketchObject has been adapted to require a solver update before moving (which also caused a non-yet-reported crash, a separate bug), and CommandCreateGeo has been adapted to trigger a solve with
auto update mode disabled. This solve is a very low cost one as the geometry is already in place.
Affected Issues
0002161
mod - src/Mod/Sketcher/App/SketchObject.cpp Diff File
mod - src/Mod/Sketcher/Gui/CommandCreateGeo.cpp Diff File

Issue History

Date Modified Username Field Change
2015-06-16 20:15 quick61 New Issue
2015-06-17 12:03 abdullah Assigned To => abdullah
2015-06-17 12:03 abdullah Status new => assigned
2015-06-17 12:22 abdullah Note Added: 0006208
2015-06-17 12:22 abdullah Status assigned => resolved
2015-06-17 12:22 abdullah Fixed in Version => 0.16
2015-06-17 12:22 abdullah Resolution open => fixed
2015-06-17 14:04 wmayer Changeset attached => FreeCAD Master master 074d5d7f
2015-06-17 14:04 wmayer Note Added: 0006210
2015-06-17 14:04 wmayer Status resolved => closed