View Issue Details

IDProjectCategoryView StatusLast Update
0000216FreeCADFeaturepublic2011-10-15 08:24
Reportercodeasylum Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.12 
Summary0000216: FreeCAD hangs on various operations
DescriptionFreeCAD hangs when creating the first item on a empty project.
Open FreeCAD. Click New. Click create a sphere. --> FreeCAD hangs on 99% CPU with steadily increasing memory until kill.
Revision 3729.

Has strong similarities with 3108976
Additional Informationcodeasylum said:
You're right. It was the "maximum deviation". Wouldn't it be nice to have
this value saved in the file too, so you can have various files with
various "maximum deviation" settings ?
TagsNo tags attached.
FreeCAD Information

Activities

wmayer

2010-11-29 13:23

administrator   ~0000442

Ah I think I got it. In the preferences under Part design > Shape view what
is the value of the parameter "Maximum deviation depending on the model
bounding box". By default this value is set to 0.2% which is a good
trade-off. In case you have set to to something very small the problem is
that the tessellation algorithms generate a huge number of triangles which
causes the hanging.

wmayer

2011-10-15 08:24

administrator   ~0001158

n this context it was suggested to have a Deviation parameter per object so that the objects can have individual deflections. This is now implemented with 5027.

Issue History

Date Modified Username Field Change
2010-11-29 13:22 wmayer New Issue
2010-11-29 13:23 wmayer Note Added: 0000442
2010-11-29 13:23 wmayer Reporter wmayer => codeasylum
2010-11-29 13:24 wmayer Assigned To => wmayer
2010-11-29 13:24 wmayer Status new => assigned
2010-11-29 13:24 wmayer Additional Information Updated
2011-02-13 18:21 yorik Relationship added parent of 0000266
2011-02-13 18:22 yorik Relationship deleted parent of 0000266
2011-10-15 08:24 wmayer Note Added: 0001158
2011-10-15 08:24 wmayer Status assigned => closed
2011-10-15 08:24 wmayer Resolution open => fixed
2011-10-15 08:24 wmayer Category Bug => Feature
2011-10-15 08:24 wmayer Fixed in Version => 0.12