View Issue Details

IDProjectCategoryView StatusLast Update
0002153FreeCADBugpublic2015-09-12 13:56
Reporterbrycenesbitt Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version14.04LTS
Product Version0.14 
Target VersionFixed in Version0.15 
Summary0002153: Undo does not work for "Measure Distance"
DescriptionUndo does not work for the measure distance tool
Steps To Reproduce
1) Enter the part workbench
2) Load a model
3) Select View->Measure Distance
4) Add a measurement
5) Regret step 0000004
6) Press CTRL-Z or Undo
7) Regret step 0000006

Workaround:
1) In the tree view, you can see and delete measurements. Of course this crashes FreeCad, but it's um better than, um something or other.
Additional InformationThe measure distance tool seems to put the number at a fairly random spot, often quite far from the body of the part.

OS: Ubuntu 14.04.2 LTS
Platform: 64-bit
Version: 0.14.2935 (Git)
Branch: master
Hash: eab159b6ee675012bf79de838c206a311e911d85
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
SoQt version: 1.6.0a
TagsNo tags attached.
FreeCAD Information

Activities

wmayer

2015-09-12 13:56

administrator   ~0006399

Undo/redo for measurement objects is implemented since v0.15

Issue History

Date Modified Username Field Change
2015-06-12 01:02 brycenesbitt New Issue
2015-09-12 13:56 wmayer Note Added: 0006399
2015-09-12 13:56 wmayer Status new => closed
2015-09-12 13:56 wmayer Assigned To => wmayer
2015-09-12 13:56 wmayer Resolution open => fixed
2015-09-12 13:56 wmayer Fixed in Version => 0.15