View Issue Details

IDProjectCategoryView StatusLast Update
0002140FreeCADBugpublic2015-12-15 13:18
Reporterstephane.magnenat Assigned Toickby  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.15 
Target VersionFixed in Version0.16 
Summary0002140: Intersection operation does not work
DescriptionIntersecting two objects does not produce the geometrically-correct result.
Steps To ReproduceLoad the attached file, use the intersection tool, see the result.
Additional InformationThese objects were created by loading SVG and extruding them, maybe this leads to broken objects.
TagsNo tags attached.
FreeCAD Information

Activities

stephane.magnenat

2015-06-01 20:20

reporter  

intersection-bug.fcstd (Attachment missing)

ickby

2015-06-02 05:53

developer   ~0006179

The imported geometry fa-path is broken as it does have a non-closed outer wire. This makes the face non-valid. Check this via python console via

>>> obj = App.ActiveDocument.getObjectsByLabel('fa-path')[0]
>>> obj.Shape.isValid()
False
>>> obj.Shape.OuterWire.isClosed()
False

This makes the extruded solid invalid and lead to the failed boolean operation. Please fix the imported path. Note that FreeCAD uses 1.e-7 as default tolerance for coincidence detection. If your svg works with lower precision consider increasing the edge and vertex tolerance of the wire before making a face from it.

I'm closing this issue as a boolean operation has undefined behaviour on broken input data, hence this is not a bug.

Issue History

Date Modified Username Field Change
2015-06-01 20:20 stephane.magnenat New Issue
2015-06-01 20:20 stephane.magnenat File Added: intersection-bug.fcstd
2015-06-02 05:53 ickby Note Added: 0006179
2015-06-02 05:53 ickby Status new => closed
2015-06-02 05:53 ickby Assigned To => ickby
2015-06-02 05:53 ickby Resolution open => fixed
2015-12-15 13:18 yorik Fixed in Version => 0.16