View Issue Details

IDProjectCategoryView StatusLast Update
0002110FreeCADBugpublic2017-07-11 20:06
ReporterSpectreTTMAssigned To 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformLenovo T410sOSWindowsOS Version 7 pro 64 bit
Product Version0.15 
Target VersionFixed in Version 
Summary0002110: BRep_API: command not done
DescriptionWhen trying to fillet some edges, message "BRep_API: command not done" and object is lost.
Steps To ReproduceUsing attached File "Long T Fused Last fillet.FCStd"
From the part workbench
Select Fusion002
Select fillet
Constant Radius
Radius 0.5
Select Edges 9,14,22,33
Hit OK
Slight Delay (HourGlass) Then Error & drawing vanishes.
Additional InformationSounds like same bug as 0000868
But different platform
TagsNo tags attached.

Relationships

related to 0000868 closed Draft BRep_API: command not done [ MAC OSX ] 

Activities

SpectreTTM

2015-05-19 20:12

reporter  

Long T Fused Last fillet.FCStd (Attachment missing)

normandc

2015-05-20 02:14

manager   ~0006150

It would have been best if you had posted about this on the FreeCAD forum. Please read the bug submission guidelines (there used to be a link to this topic on the bug report form, not sure where it went): http://forum.freecadweb.org/viewtopic.php?f=3&t=5236

Fillets are tricky in any CAD software, more so in FreeCAD but this is due to the third-party geometric modeling kernel it uses, Open Cascade. It does not deal well with such cases as multiple edges meeting on an inward vertex as in your model. In this regard, this cannot be fixed in FreeCAD because the FreeCAD team has no control over Open Cascade's failings. This would need to be reported upstream (on the Open Cascade bug tracker).

That being said, what is left to end users is to work around these problems.
1. Fillets should be applied last in the construction of a model, unless absolutely necessary. You applied fillets to your model early on which is not a good idea.
2. The boolean fusions in your model left many residual edges on faces which may cause problems with fillets. Before applying fillets, you should apply a Refine shape feature from the OpenSCAD workbench. There is a Refine shape tool in the Part menu, but it produces a new solid that is unlinked to prior operations.
3. Play with the order of fillet selection until you get what you want. It may require many tries, and more than one fillet operation to succeed.

normandc

2015-05-20 02:35

manager   ~0006151

I think the way you constructed your model may prevent success with the inner vertical fillets. In my experience it is preferable to cut material from a bigger block than to fuse material to a smaller one.

File named "Long T Fused Last fillet_normandc1.fcstd" was made by deleting all your fillets, fusing the primitives shapes together, applying an OpenSCAD Refine Shape feature, then applying fillets. It apparently succeeds, but Check geometry tool in the Part workbench shows it's invalid if the RunBOPCheck parameter (Edit --> Parameters/Preferences/Mod/Part/CheckGeometry) is set to true. If set to false, no error is detected.

File named "Long T Fused_PartDesign_normandc2.fcstd" shows an alternative workflow using the PartDesign workbench. The file is deemed valid by Check Geometry with RunBOPCheck set to either true or false.

normandc

2015-05-20 02:35

manager  

Long T Fused Last fillet_normandc1.fcstd (Attachment missing)

normandc

2015-05-20 02:35

manager  

Long T Fused_PartDesign_normandc2.fcstd (Attachment missing)

mattmiller

2015-07-26 23:25

reporter   ~0006259

Last edited: 2015-07-26 23:30

View 3 revisions

I can reliably and in simple procedure reproduce this issue.

1: Open a new or already opened instance of FreeCAD
2: start a new document
3: generate a cube
4: resize the cube's dimensions
5: try to do any fillet or chamfering

If you leave out step 4, then the bug does not occur.

Thanks for the kickass program, and I hope this helps solve the "BRep_API: command not done" issue.

yorik

2015-08-05 02:22

administrator   ~0006271

Works for me, I can follow the above procedure without problems...

Kunda1

2017-01-25 12:58

administrator   ~0007984

No response from @SpectreTTM
Resolving as 'unable to reproduce'

wmayer

2017-01-25 16:25

administrator   ~0007985

In either case that's an OCC bug and can only be fixed by using a newer version.

Issue History

Date Modified Username Field Change
2015-05-19 20:12 SpectreTTM New Issue
2015-05-19 20:12 SpectreTTM File Added: Long T Fused Last fillet.FCStd
2015-05-20 02:14 normandc Note Added: 0006150
2015-05-20 02:35 normandc Note Added: 0006151
2015-05-20 02:35 normandc File Added: Long T Fused Last fillet_normandc1.fcstd
2015-05-20 02:35 normandc File Added: Long T Fused_PartDesign_normandc2.fcstd
2015-07-26 23:25 mattmiller Note Added: 0006259
2015-07-26 23:30 mattmiller Note Edited: 0006259 View Revisions
2015-07-26 23:30 mattmiller Note Edited: 0006259 View Revisions
2015-08-05 02:22 yorik Note Added: 0006271
2015-08-05 02:22 yorik Status new => feedback
2017-01-19 15:24 Kunda1 Relationship added related to 0000868
2017-01-19 15:25 Kunda1 Tag Attached: #pending
2017-01-25 12:58 Kunda1 Note Added: 0007984
2017-01-25 12:58 Kunda1 Status feedback => resolved
2017-01-25 12:58 Kunda1 Resolution open => unable to reproduce
2017-01-25 12:58 Kunda1 Assigned To => Kunda1
2017-01-25 12:59 Kunda1 Additional Information Updated View Revisions
2017-01-25 12:59 Kunda1 Assigned To Kunda1 =>
2017-01-25 16:25 wmayer Note Added: 0007985
2017-01-25 16:25 wmayer Status resolved => closed
2017-07-11 20:06 Kunda1 Tag Detached: #pending