View Issue Details

IDProjectCategoryView StatusLast Update
0002080FEM[FreeCAD] Bugpublic2017-10-18 17:53
Reporterpfirszt Assigned Towmayer  
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version[FreeCAD] 0.17Fixed in Version[FreeCAD] 0.17 
Summary0002080: Attempt to remove FEM analysis result (displacement & stress) results in false warning
DescriptionAttempt to remove FEM analysis result (displacement & stress) results in false warning: "This object is referenced by other objects and thus these objects might get broken. Are you sure to continue?"
Steps To ReproduceRun analysis, select Displacement or MissesStress, press "Del" key
Additional Informationhttp://forum.freecadweb.org/viewtopic.php?f=18&t=10771&p=86698#p86695
TagsFEM
FreeCAD Information

Activities

berndhahnebach

2016-07-28 23:28

developer   ~0007225

PopUp is still in 0.17.8048. Yes, we should may be remove that popup. It is not needed.

berndhahnebach

2017-01-24 12:15

developer   ~0007951

PopUp still in 0.17.9791. The PopUp pops up on press del dey for any analysis member. If the results are deleted by purge results command the popup does not pop up.

I'm gone give it a try if it is possible to solve in python.

bernd

berndhahnebach

2017-01-24 20:58

developer   ~0007971

I opened a forum topic http://forum.freecadweb.org/viewtopic.php?f=18&t=20196

Kunda1

2017-02-20 22:26

administrator   ~0008391

wmayer responds in the thread:
This behaviour is implemented directly in the "Delete" command (StdCmdDelete::activated). However, at this point the command doesn't really know the context in which the deletion is performed. Only the view provider should decide if a deletion might break something or not because it knows best the internal structure.

Currently the deletion of FEM results is one of the few examples where this dialog is really annoying but it's not a FEM specific issue, it's a general issue.

I have to think about how to improve all this...

wmayer

2017-10-18 17:53

administrator   ~0010319

https://github.com/FreeCAD/FreeCAD/commit/c1542e24015e8103185ef47fb8fb2215a6f4df38
https://github.com/FreeCAD/FreeCAD/commit/dcaf263e4c36215bbf09d11d57909e60b5ad5f2e

Issue History

Date Modified Username Field Change
2015-05-01 13:54 pfirszt New Issue
2016-03-21 16:44 berndhahnebach Tag Attached: FEM
2016-03-22 10:49 berndhahnebach Project FreeCAD => FEM
2016-07-28 23:28 berndhahnebach Note Added: 0007225
2017-01-24 12:15 berndhahnebach Note Added: 0007951
2017-01-24 12:38 berndhahnebach Status new => confirmed
2017-01-24 20:58 berndhahnebach Note Added: 0007971
2017-02-20 22:26 Kunda1 Note Added: 0008391
2017-02-20 22:27 Kunda1 Target Version => 0.17
2017-10-18 17:53 wmayer Assigned To => wmayer
2017-10-18 17:53 wmayer Status confirmed => closed
2017-10-18 17:53 wmayer Resolution open => fixed
2017-10-18 17:53 wmayer Fixed in Version => 0.17
2017-10-18 17:53 wmayer Note Added: 0010319