View Issue Details

IDProjectCategoryView StatusLast Update
0002061FreeCADBugpublic2017-03-17 22:13
Reporterplaes Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.15 
Target VersionFixed in Version0.17 
Summary0002061: Toolbar location settings are not saved or loaded correctly
DescriptionWhen customizing toolbars and closing and reopening Freecad, toolbars are first not visible, and after reloading the proper view, the toolbars reappear, but not in the previous locations.
Steps To Reproduce1. Create new toolbar
2. Edit and rearrange toolbar buttons
3. Move toolbar to a custom location
4. Exit and start Freecad again
5. Observe that toolbars are "lost"
Additional InformationYoutube video showing the issue: https://youtu.be/GcgoXgCp-u4?t=817 (starts from 13:37, after the toolbars have been modified.)


I have reproduced it in Linux version 0.15 and the video also shows 0.15 on Windows.
TagsNo tags attached.
FreeCAD Information

Relationships

has duplicate 0002247 closedian.rees PartDesign Toolbar positions are not kept across application reinstantiation 

Activities

yorik

2015-04-18 17:00

administrator   ~0006043

Toolbar positions are saved for a certain workbench only. You might need to change the default start workbench in the preferences to the workbench where you added the custom toolbars...

triplus

2015-04-18 17:45

developer   ~0006044

Yes, only in workbench that is set as default under Start up (FreeCAD preferences) the toolbars will persist its position after restart of FreeCAD. This is known limitation and not necessary a bug somebody will fix soon. At least that is how i understand it from past explanations.

There is one "trick" you can use. Create custom toolbars and use the same name for toolbars in different workbenches. All toolbars in different workbenches with the same name as the name of the toolbar in Start up workbench will have the same position. For example all toolbars named left_edge will persist on left edge if the toolbar named left_edge in Start up workbench will be positioned on the left edge.

Kunda1

2017-01-23 21:43

administrator   ~0007930

Is 0002247 a dupe ?

Kunda1

2017-01-23 22:03

administrator   ~0007933

As per @triplus in https://forum.freecadweb.org/viewtopic.php?f=10&t=20165#p155442
When i finish the work on NavigationIndicator i will evaluate if PersistentToolbars module should be upstreamed. If that will happen this issue should be resolved.

severoraz

2017-02-04 08:52

reporter   ~0008207

Last edited: 2017-02-04 10:02

View 2 revisions

Kunda1, you asked me on 0002247 to retest on FreeCAD 0.16 and to post the info about my FreeCAD copy, I will answer here because the other bug is closed.

Retest on FreeCAD 0.16. To test it, I opened the Part Design from the default startup page and just played around with the toolbar. After a minute, I closed FreeCAD and reopened. In the newly opened instance, I picked Part Design again and the toolbar was as I had customized it, which is good! However, I changed it a bit more, repeated, and then the changes were not saved. Perhaps I should ask, what is the trigger for FreeCAD to save a toolbar modification? The modification itself doesn't seem to be triggering this.

Now, on to my FreeCAD copy data:

OS: Linux
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.Unknown
Build type: Release
Python version: 2.7.13
Qt version: 4.8.7
Coin version: 3.1.3
OCC version: 6.9.1

Kunda1

2017-02-04 10:07

administrator   ~0008208

@severoraz See 0002061:0007933
triplus is referring to a macro called PerisitentToolbars: https://github.com/triplus/PersistentToolbars
It can be installed via
https://github.com/FreeCAD/FreeCAD-addons#installing
but I'm not sure it fully works yet.

triplus

2017-03-17 22:05

developer   ~0008643

This issue report can now be closed as it was fixed.

https://github.com/FreeCAD/FreeCAD/pull/609

Kunda1

2017-03-17 22:11

administrator   ~0008644

Attached commit FreeCAD master 9c821564 to this ticket.
Btw, @triplus at your convenience please read https://freecadweb.org/wiki/tracker#GitHub_and_MantisBT this way tickets can be linked and closed remotely via keywords in

Kunda1

2017-03-17 22:13

administrator   ~0008645

Attached commit FreeCAD master 9c821564 to this ticket.
Btw, @triplus at your convenience please read https://freecadweb.org/wiki/tracker#GitHub_and_MantisBT this way tickets can be linked and closed remotely via keywords in the git commit message.
Closing.

PS I couldn't attribute this ticket to triplus. I guess he's doesn't have developer privs on MantisBT yet.

Related Changesets

FreeCAD: master 9c821564

2017-03-11 21:58:35

triplus


Committer: yorik Details Diff
Persistent toolbars for FreeCAD Affected Issues
0002061
mod - src/Mod/Tux/CMakeLists.txt Diff File
mod - src/Mod/Tux/InitGui.py Diff File
add - src/Mod/Tux/PersistentToolbars.py Diff File
add - src/Mod/Tux/PersistentToolbarsGui.py Diff File

Issue History

Date Modified Username Field Change
2015-04-18 05:39 plaes New Issue
2015-04-18 17:00 yorik Note Added: 0006043
2015-04-18 17:45 triplus Note Added: 0006044
2017-01-23 21:42 Kunda1 Relationship added related to 0002247
2017-01-23 21:43 Kunda1 Note Added: 0007930
2017-01-23 22:03 Kunda1 Note Added: 0007933
2017-01-23 22:03 Kunda1 Relationship replaced has duplicate 0002247
2017-02-04 08:52 severoraz Note Added: 0008207
2017-02-04 10:02 Kunda1 Note Edited: 0008207 View Revisions
2017-02-04 10:07 Kunda1 Note Added: 0008208
2017-03-17 22:05 triplus Note Added: 0008643
2017-03-17 22:08 Kunda1 Changeset attached => FreeCAD master 9c821564
2017-03-17 22:11 Kunda1 Note Added: 0008644
2017-03-17 22:13 Kunda1 Status new => closed
2017-03-17 22:13 Kunda1 Resolution open => fixed
2017-03-17 22:13 Kunda1 Fixed in Version => 0.17
2017-03-17 22:13 Kunda1 Note Added: 0008645