View Issue Details

IDProjectCategoryView StatusLast Update
0002050FreeCADBugpublic2017-01-27 03:41
Reporterdrei Assigned Toyorik  
PrioritynormalSeverityblockReproducibilitysometimes
Status closedResolutionfixed 
Platform64 bitOSArch LinuxOS Version
Product Version 
Target VersionFixed in Version0.16 
Summary0002050: FreeCAD freezes when adding a Draft Dimension
DescriptionOpening the file and attempting to create a Draft dimension generates a freeze in FreeCAD.

OS: Linux
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.4805 (Git)
Branch: master
Hash: 3e1e5974f0b064a7e357cd593227c1cd21901bdb
Python version: 2.7.9
Qt version: 4.8.6
Coin version: 3.1.3
OCC version: 6.8.0.oce-0.17
Steps To ReproduceSee video:
http://youtu.be/NcG08wg1etg

Open FreeCAD
Open attached file
Go to Draft Workbench
Select Working Plane
Select Add Dimension
Select Origin

Additional InformationForum post:
http://forum.freecadweb.org/viewtopic.php?f=3&t=10502

User quick61 mentions he was unable to reproduce the issue.

gdb is unable to present information from bt since I am forced to do killall freecad in order to exit it.

Here's what I can get from the terminal:
gdb ./FreeCAD
GNU gdb (GDB) 7.9
Copyright (C) 2015 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ./FreeCAD...(no debugging symbols found)...done.
(gdb) run
Starting program: /home/isaac/Programs/Original/build/bin/FreeCAD
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
FreeCAD 0.16, Libs: 0.16R4783 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2015
  ##### #### ### ####
  # # # # # #
  # ## #### #### # # # # #
  #### # # # # # # # ##### # #
  # # #### #### # # # # #
  # # # # # # # # # ## ## ##
  # # #### #### ### # # #### ## ## ##

[New Thread 0x7fff937fe700 (LWP 1270)]
[New Thread 0x7fff92ffd700 (LWP 1271)]
Draft workbench activated
Pick a face to define the drawing plane
Pick first point:
[Thread 0x7fff937fe700 (LWP 1270) exited]
[Thread 0x7fff92ffd700 (LWP 1271) exited]
kill
[Thread 0x7ffff7f897c0 (LWP 1262) exited]

Program terminated with signal SIGKILL, Killed.
The program no longer exists.
(gdb) kill
The program is not being run.
(gdb) bt
No stack.
(gdb)


However, other times it works perfectly.


TagsOCC Bug
FreeCAD Information

Relationships

parent of 0001931 closedwmayer FreeCAD migration to OCCT 7.1 
parent of 0002057 closedwmayer FreeCAD BoundBox.h doesn't work with 2D objects 
related to 0002182 closedkkremitzki Draft Dimension tool in Draft workbench is freezing 

Activities

drei

2015-04-12 19:08

reporter  

robot_automatismos.fcstd (Attachment missing)

rockn

2015-04-12 20:26

developer   ~0006008

It seem that it is the Intersection snap tool that cause the freeze.

yorik

2015-04-12 22:59

administrator   ~0006009

I can't reproduce this problem, either with the intersection snap or not (I also tried several combinations). It is true that snapping gets slower when all the snap tools are turned on, but it doesn't freeze, and I can select the central intersection...

triplus

2015-04-12 23:27

developer   ~0006010

I can confirm enabling Intersection snap produces this behaviour. It works fast with all other snap modes enabled except for Intersection snap. Disabling al other snap modes and enabling just Intersection snap will produce reported behaviour in few seconds.

P.S. Ubuntu 14.04 + Daily PPA.

shoogen

2015-04-13 09:27

developer   ~0006012

Last edited: 2015-04-13 10:20

View 2 revisions

I think i can reproduce the problem in DRAWEXE
> time "distmini d s1 s2"

http://tracker.dev.opencascade.org/view.php?id=26064

shoogen

2015-04-13 17:44

developer   ~0006014

could everybody please tell if he used a debug or a release build when trying to reproduce the problem.

rockn

2015-04-13 18:02

developer   ~0006015

Hi Shoogen,
I don't really know... :(
I build FreeCAD :
OS: Ubuntu 14.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.4806 (Git)
Branch: master
Hash: a7c346606fe588b0f2faa251e3ae72e9ef833184
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

I usually just check FREECAD_USE_EXTERNAL_PIVY and in this case BUILD_FEM_NETGEN.
I think I have read that debug is automatically ON.
How can I check that please ?

triplus

2015-04-13 19:17

developer   ~0006016

IFAIK Ubuntu daily PPA builds are now by default release builds due to discovered reduced sketcher performance when using debug builds.

Therefore i am using release build.

drei

2015-04-13 21:03

reporter   ~0006017

My complete CMake Configuration

cmake ../FreeCAD_Master -DPYTHON_EXECUTABLE=/usr/bin/python2 -DFREECAD_USE_EXTERNAL_PIVY=1 -DBUILD_FEM=1 -DBUILD_CAM=0 -DBUILD_COMPLETE=0 -DBUILD_IMAGE=0 -DBUILD_INSPECTION=0 -DBUILD_OPENSCAD=0 -DBUILD_PLOT=0 -DBUILD_POINTS=0 -DBUILD_REVERSEENGINEERING=0 -DBUILD_SHIP=0 -DBUILD_ROBOT=0 -DBUILD_SPREADSHEET=1 -DBUILD_ASSEMBLY=0 -DCMAKE_BUILD_TYPE=Release -DFREECAD_USE_3DCONNEXION=0 -DNGLIB_INCLUDE_DIR=/opt/netgen/lib

I'll test with Debug later today.

drei

2015-04-13 23:08

reporter   ~0006018

Made a debug build.
I let the software stay for a while after the freeze and in recovered. I'm still unable to get bt output.

CMake config:
cmake ../FreeCAD_Master -DPYTHON_EXECUTABLE=/usr/bin/python2 -DFREECAD_USE_EXTERNAL_PIVY=1 -DBUILD_FEM=1 -DBUILD_CAM=0 -DBUILD_COMPLETE=0 -DBUILD_IMAGE=1 -DBUILD_INSPECTION=0 -DBUILD_OPENSCAD=0 -DBUILD_PLOT=0 -DBUILD_POINTS=0 -DBUILD_REVERSEENGINEERING=0 -DBUILD_SHIP=0 -DBUILD_ROBOT=0 -DBUILD_SPREADSHEET=1 -DBUILD_ASSEMBLY=0 -DCMAKE_BUILD_TYPE=Debug -DFREECAD_USE_3DCONNEXION=0 -DNGLIB_clear


gdb output:
(gdb) run
The program being debugged has been started already.
Start it from the beginning? (y or n) y
Starting program: /home/isaac/Programs/Original/build/bin/FreeCAD
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
FreeCAD 0.16, Libs: 0.16R4812 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2015
  ##### #### ### ####
  # # # # # #
  # ## #### #### # # # # #
  #### # # # # # # # ##### # #
  # # #### #### # # # # #
  # # # # # # # # # ## ## ##
  # # #### #### ### # # #### ## ## ##
Attach observer 0x908a00
Attach observer 0x91c640
Attach observer 0xfe4310
Attach observer 0x10342f8
Attach observer 0x10374f8
Attach observer 0x10374f8
Attach observer 0x10fde70
[New Thread 0x7fff93218700 (LWP 3511)]
Attach observer 0x1bfb318
Attach observer 0x1ba4d90
Draft workbench activated
Pick first point:
DraftGeomUtils: Unsupported curve type: (<BSplineCurve object>, <Line (-16,6,0) (0.0914546,6,0) >)
DraftGeomUtils: Unsupported curve type: (<BSplineCurve object>, <Line (-30,-36,0) (-30,-38.8482,0) >)
DraftGeomUtils: Unsupported curve type: (<BSplineCurve object>, <Line (-30,-36,0) (-30,-38.8979,0) >)
DraftGeomUtils: Unsupported curve type: (<BSplineCurve object>, <Line (-30,-36,0) (-30,-38.9103,0) >)
DraftGeomUtils: Unsupported curve type: (<BSplineCurve object>, <Line (-30,-36,0) (-30,-41.0592,0) >)
DraftGeomUtils: Unsupported curve type: (<BSplineCurve object>, <Line (0,0,0) (-0.690785,-0.723034,-0.00625354) >)
DraftGeomUtils: Unsupported curve type: (<BSplineCurve object>, <Line (-30,-36,0) (-30,-39.9351,0) >)
DraftGeomUtils: Unsupported curve type: (<BSplineCurve object>, <Line (-30,-36,0) (-30,-39.9351,0) >)
Pick first point:
[Thread 0x7fff93218700 (LWP 3511) exited]
DraftGeomUtils: Unsupported curve type: (<BSplineCurve object>, <Line (0,0,0) (-8.5,0,0) >)
Detach observer 0x1bfb318
Detach observer 0x1ba4d90
Detach observer 0x91c640
Detach observer 0x10374f8
Detach observer 0x10374f8
Detach observer 0xfe4310
Detach observer 0x10342f8
Detach observer 0x10fde70
Detach observer 0x908a00
[Thread 0x7ffff7f887c0 (LWP 3506) exited]
[Inferior 1 (process 3506) exited normally]
(gdb) bt
No stack.

yorik

2015-04-13 23:17

administrator   ~0006019

Okay I got it to crash too... If you keep hovering the mouse without clicking for a minute or two, it indeed ends up freezing, but not necessarily on the center of the model, and not necessarily with the dimension tool. Gdb doesn't register a crash.

shoogen's find might be related, but maybe not the culprit... I still couldn't make sure if only the intersection snap causes the freeze

shoogen

2015-04-14 06:31

developer   ~0006020

The shapes that caused the problem were parallel lines.
>>> App.ActiveDocument.dist1_s1.Shape.BoundBox
BoundBox (-16, -36, 0, -7.5, -36, 0)
>>> App.ActiveDocument.dist1_s2.Shape.BoundBox
BoundBox (-18, 11, 0, -7.10543e-15, 11, 0)
Perhaps it makes sense to check the Bounding Box before calling dist2shape.

shoogen

2015-04-14 06:40

developer   ~0006021

git fetch git://github.com/5263/FreeCAD dev-snapinter

yorik

2015-04-14 13:14

administrator   ~0006024

Added, thanks! Let's see if it solves...

shoogen

2015-04-14 15:12

developer   ~0006025

http://tracker.dev.opencascade.org/view.php?id=26075

drei

2015-04-17 04:22

reporter   ~0006036

I'll keep on testing a bit with the file, but the problem appears to have been solved.

triplus

2015-04-17 15:04

developer   ~0006037

Last edited: 2015-04-17 15:04

View 2 revisions

I can confirm enabling Intersection snap does not produce this behaviour any more.

yorik

2015-04-17 16:40

administrator   ~0006038

Okay, let's close this report then? If anyone needs to, please reopen!

shoogen

2015-04-17 19:37

developer   ~0006040

I don't consider completely disabling the distToShape call a "solution"

yorik

2017-01-11 16:45

administrator   ~0007632

I think this can be closed, I don't know what else needs to be done here...

Related Changesets

FreeCAD: master 7ddd9d2c

2015-04-14 08:37:53

shoogen


Committer: yorik Details Diff
check BoundingBox before calling distToShape

to find intersecting edges. issue 0002050
Affected Issues
0002050
mod - src/Mod/Draft/DraftGeomUtils.py Diff File

Issue History

Date Modified Username Field Change
2015-04-12 19:08 drei New Issue
2015-04-12 19:08 drei File Added: robot_automatismos.fcstd
2015-04-12 20:26 rockn Note Added: 0006008
2015-04-12 22:59 yorik Note Added: 0006009
2015-04-12 23:27 triplus Note Added: 0006010
2015-04-13 09:27 shoogen Note Added: 0006012
2015-04-13 09:27 shoogen Tag Attached: OCC Bug
2015-04-13 10:20 shoogen Note Edited: 0006012 View Revisions
2015-04-13 10:20 shoogen Assigned To => shoogen
2015-04-13 10:20 shoogen Status new => assigned
2015-04-13 10:21 shoogen Status assigned => acknowledged
2015-04-13 17:44 shoogen Note Added: 0006014
2015-04-13 18:02 rockn Note Added: 0006015
2015-04-13 19:17 triplus Note Added: 0006016
2015-04-13 21:03 drei Note Added: 0006017
2015-04-13 23:08 drei Note Added: 0006018
2015-04-13 23:17 yorik Note Added: 0006019
2015-04-14 06:31 shoogen Note Added: 0006020
2015-04-14 06:31 shoogen Assigned To shoogen => yorik
2015-04-14 06:31 shoogen Status acknowledged => assigned
2015-04-14 06:40 shoogen Note Added: 0006021
2015-04-14 06:40 shoogen Status assigned => feedback
2015-04-14 13:14 yorik Note Added: 0006024
2015-04-14 13:20 yorik Changeset attached => FreeCAD Master master 7ddd9d2c
2015-04-14 15:12 shoogen Note Added: 0006025
2015-04-14 15:12 shoogen Relationship added parent of 0001931
2015-04-15 08:22 shoogen Relationship added parent of 0002057
2015-04-17 04:22 drei Note Added: 0006036
2015-04-17 04:22 drei Status feedback => assigned
2015-04-17 15:04 triplus Note Added: 0006037
2015-04-17 15:04 triplus Note Edited: 0006037 View Revisions
2015-04-17 16:40 yorik Note Added: 0006038
2015-04-17 16:41 yorik Status assigned => closed
2015-04-17 16:41 yorik Resolution open => fixed
2015-04-17 16:41 yorik Fixed in Version => 0.16
2015-04-17 19:37 shoogen Note Added: 0006040
2015-04-17 19:37 shoogen Status closed => feedback
2015-04-17 19:37 shoogen Resolution fixed => reopened
2017-01-11 16:45 yorik Note Added: 0007632
2017-01-11 16:45 yorik Status feedback => closed
2017-01-11 16:45 yorik Resolution reopened => fixed
2017-01-27 03:41 Kunda1 Relationship added related to 0002182