View Issue Details

IDProjectCategoryView StatusLast Update
0002049FreeCADBugpublic2016-02-28 11:18
Reporterdrewdiller Assigned Towmayer  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindows 8OS Version8
Product Version 
Target VersionFixed in Version0.16 
Summary0002049: 0.15 and 0.16 Part Revolve ignores unit accuracy setting beyond 2 decimals
DescriptionThere is a workaround for the following annoyance:

A fully constrained sketch of a rectangle can have any of its line segments act as the rotation axis. If the rotation axis happens to have a constraint that is more than two decimals precise, it'll succeed in making the Revolve object. The problem is that it clearly becomes rounded, for example 0.175 becomes 0.18.

The workaround it is to inspect the Data of the new Revolve object after it has been created, and alter its Base -> x value to the intended value.

If the workaround is not followed, the resulting Revolve is hollow with a thin tube in the center.

If the workaround is followed, the resulting Revolved is a cylinder, as intended.
Steps To ReproduceOpen FreeCAD 0.15 or 0.16, any sub version.
Open attached "revolve_example_problem_with_three_decimals.FCStd".
Make sure your Unit precision is something more precise than targeted, I use "4".
Activate the Part workbench.
Select the "revolve_sketch" sketch.
Click the Revolve button.
Tick "Create Solid" box.
Click "Select line in 3D view" button.
Select the left most edge of the sketch rectangle.
The X value for the revolve axis should now be 30.175.
Click OK.
Type number 0 for a diagonal view, observe that the Revolve is hollow, with a thin center rod.
Additional InformationI'm not interested in making cylinders, this is a reduced-test-case example.

I have some screenshots, but I am limited in how many files I can attach on this initial but report screen. Hopefully I can attach more files soon.
TagsNo tags attached.

Activities

drewdiller

2015-04-12 18:13

reporter  

revolve_example_problem_with_three_decimals.FCStd (Attachment missing)

drewdiller

2015-04-12 18:13

reporter  

Capture1.PNG (Attachment missing)

drewdiller

2015-04-12 18:13

reporter  

Capture2.PNG (Attachment missing)

Related Changesets

FreeCAD: master 3f15ae80

2016-02-28 12:12:10

wmayer

Details Diff
+ fixes 0002049: 0.15 and 0.16 Part Revolve ignores unit accuracy setting beyond 2 decimals Affected Issues
0002049
mod - src/Mod/Part/Gui/DlgRevolution.cpp Diff File

Issue History

Date Modified Username Field Change
2015-04-12 18:13 drewdiller New Issue
2015-04-12 18:13 drewdiller File Added: revolve_example_problem_with_three_decimals.FCStd
2015-04-12 18:13 drewdiller File Added: Capture1.PNG
2015-04-12 18:13 drewdiller File Added: Capture2.PNG
2016-02-28 11:13 wmayer Changeset attached => FreeCAD Master master 3f15ae80
2016-02-28 11:13 wmayer Assigned To => wmayer
2016-02-28 11:13 wmayer Status new => closed
2016-02-28 11:13 wmayer Resolution open => fixed
2016-02-28 11:18 wmayer Fixed in Version => 0.16