View Issue Details

IDProjectCategoryView StatusLast Update
0002036FreeCADBugpublic2017-03-10 20:35
ReporterjalapenoAssigned ToKunda1 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSUbuntuOS Version14.04.2
Product Version 
Target VersionFixed in Version0.16 
Summary0002036: Part Extrude with Taper Angle != 0 Fails
DescriptionCreating an extrusion with a non-zero taper angle fails to produce an edge (or surface).

OS: Ubuntu 14.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.4740 (Git)
Branch: master
Hash: 32688a636b0c8487d10d6d6e14fe1cab5e4f3696
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
Steps To Reproduce1) Select Sketcher Workbench
2) Create a new sketch, XY plane.
3) Create a Circle.
4) Anchor circle centre to origin.
5) Set circle radius to 40mm.
6) Close sketch
7) Set workbench to Part
8) Select sketch
9) Extrude
10) Extrude direction [0, 0, 1]
11) Extrude length 10mm
12) Taper outward angle = 0 deg
13) Create solid = No
14) OK
15) Observe that a stubby cylinder is created.
16) Select the extrusion in the model tree.
17) Select the data tab
18) Locate the taper angle. Observe that it is 0.
19) Change the taper angle to 5 and press enter
20) Observe that the cylinder has vanished. I expected a conical section.
21) Change the taper angle to -5 and press enter
22) Observe that the cylinder has vanished. I expected a conical section.
23) Change the taper angle to 0 and press enter.
24) Observe that the cylinder has re-appeared.
Additional Information
A similar problem exists when creating a solid. The edge of the circle does not appear.
TagsOCC Bug, upstream

Activities

jalapeno

2015-04-03 12:24

reporter  

Extruded_Cylinder_TaperAngle=1.png (Attachment missing)

shoogen

2015-04-04 08:23

developer   ~0005963

It would be great if you could attach a FCStd file.

wmayer

2015-04-05 14:30

administrator   ~0005966

Confirmed with:
OS: Ubuntu 12.04.5 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.4742 (Git)
Branch: master
Hash: d13c279d5abb5c27784f655ed890a5ba07518d52
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
OCC version: 6.8.0.oce-0.17


But it doesn't happen with:
OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.4744 (Git)
Branch: master
Hash: d3af1ea85a242393a97446e558b606cf3ce307a0
Python version: 2.7.6
Qt version: 4.8.5
Coin version: 4.0.0a
OCC version: 6.6.0

The geometry check reports a problem with the wire of the extruded shape that it's not closed. However, it doesn't complain about the input sketch.

wmayer

2015-04-05 14:30

administrator  

0002036.fcstd (Attachment missing)

jalapeno

2015-04-05 21:16

reporter  

Extrude_Taper_Angle_Problem.fcstd (Attachment missing)

jalapeno

2015-04-05 21:24

reporter   ~0005968

The defect occurs with

OS: Ubuntu 14.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.4747 (Git)
Branch: master
Hash: 960be3c809140e1beeb019ecfee6909c39e3d3c6
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17


But doesn't occur with

OS: Ubuntu 14.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.4701 (Git)
Branch: master
Hash: f6d50e6f33d71a533d18707aa3d74d0d45a5fc28
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.7.1

So a bisection between 0.16.4701 and 0.16.4740 may yield the commit that caused the problem.

My file Extrude_Taper_Angle_Problem.fcstd was produced with 0.16.4701, which works properly.

The attachment 0002036.fcstd was produced with a faulty version, and has been saved with the fault captured.

To reproduce the fault, the taper angle of the extrusion must be adjusted to force the surface to be re-computed.

wmayer

2015-04-06 07:47

administrator   ~0005969

> So a bisection between 0.16.4701 and 0.16.4740 may yield the commit that caused the problem.
No. Look at the versions numbers I posted. For rev. 4744 it works with OCC 6.6 but for rev.4742 it fails with OCC 6.8. So, it must be related somehow to OCC. Either OCC is less error tolerant or it's simply a regression.

tanderson69

2015-04-06 13:45

developer  

pcurves.png (Attachment missing)

tanderson69

2015-04-06 13:46

developer   ~0005970

Last edited: 2015-04-06 13:54

View 2 revisions

I agree with Werner, this is a regression. I have a command here that dumps out the pcurves from a face. I have uploaded a screen dump of this commands results. You will notice that 2 curves lie on the umax periodic boundary. From my experience with model refine, this happens frequently with occ algorithms and is one source of our many needed calls to shapefix_face. Another clue is that the problem goes away if you leave the circle slightly open. Edit: I didn't make my point very clear above. Shapefix_face will correct this problem.

related note: Shouldn't makeDraft work for just an edge also.
Standard_Failure::Raise("Only a wire or a face is supported");

shoogen

2015-04-07 06:28

developer   ~0005971

Last edited: 2015-04-07 06:37

View 4 revisions

Shouldn't this be a bug in lofting (or creating a ruled surface)? AFAIK we don't use the tapering function of OCCT.

Please also keep in mind that was a regression in the offset function (API).
http://forum.freecadweb.org/viewtopic.php?f=8&t=9122
commit 17a85e4352b35a536a73f7d4f91b011446652e97
http://tracker.dev.opencascade.org/view.php?id=25705

shoogen

2015-04-07 06:44

developer   ~0005972

Last edited: 2015-04-07 13:59

View 2 revisions

I can't reproduce the problem from 0002036.fcstd in
OS: Debian GNU/Linux 7.8 (wheezy)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.4748 +362 (Git)
Branch: danfalck/path-module,dev-skiprecompute,dev-fuzzyboolean
Hash: 6e77ca27f137955d0088c181c59e313c30948f19
Python version: 2.7.3
Qt version: 4.8.2
Coin version: 4.0.0a
OCC version: 6.9.0.beta-41ed1ed

After a a recompute the Extrude has a valid shape.

I would expect to this problem to be solved by migrating to OCCT 6.9.0

Kunda1

2017-01-15 04:50

administrator   ~0007780

> I would expect to this problem to be solved by migrating to OCCT 6.9.0
@shoogen can you confirm that it is indeed solved?

Kunda1

2017-01-24 18:46

administrator   ~0007967

bumped forum thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=9122&p=155683#p155683

cox

2017-01-24 19:09

reporter   ~0007968

I can not reproduce:

OS: "Arch Linux"
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.9790 (Git)
Build type: Release
Branch: master
Hash: 294b2308d660a4aae11e90ec22f96ca56190bcd1
Python version: 2.7.13
Qt version: 4.8.7
Coin version: 3.1.3
OCC version: 6.9.1

Kunda1

2017-01-24 19:16

administrator   ~0007969

Resolving. This issue should be fixed in all builds that include OCCT >=v6.9.0
If not please re-open ticket.

Issue History

Date Modified Username Field Change
2015-04-03 12:24 jalapeno New Issue
2015-04-03 12:24 jalapeno File Added: Extruded_Cylinder_TaperAngle=1.png
2015-04-04 08:23 shoogen Note Added: 0005963
2015-04-05 14:30 wmayer Note Added: 0005966
2015-04-05 14:30 wmayer File Added: 0002036.fcstd
2015-04-05 21:16 jalapeno File Added: Extrude_Taper_Angle_Problem.fcstd
2015-04-05 21:24 jalapeno Note Added: 0005968
2015-04-06 07:47 wmayer Note Added: 0005969
2015-04-06 13:45 tanderson69 File Added: pcurves.png
2015-04-06 13:46 tanderson69 Note Added: 0005970
2015-04-06 13:54 tanderson69 Note Edited: 0005970 View Revisions
2015-04-06 15:16 shoogen Tag Attached: OCC Bug
2015-04-07 06:28 shoogen Note Added: 0005971
2015-04-07 06:29 shoogen Note Edited: 0005971 View Revisions
2015-04-07 06:31 shoogen Note Edited: 0005971 View Revisions
2015-04-07 06:37 shoogen Note Edited: 0005971 View Revisions
2015-04-07 06:44 shoogen Note Added: 0005972
2015-04-07 13:59 shoogen Note Edited: 0005972 View Revisions
2017-01-15 04:49 Kunda1 Tag Attached: upstream
2017-01-15 04:50 Kunda1 Note Added: 0007780
2017-01-24 18:46 Kunda1 Note Added: 0007967
2017-01-24 18:47 Kunda1 Tag Attached: #pending
2017-01-24 18:49 Kunda1 Status new => feedback
2017-01-24 19:09 cox Note Added: 0007968
2017-01-24 19:16 Kunda1 Note Added: 0007969
2017-01-24 19:16 Kunda1 Status feedback => resolved
2017-01-24 19:16 Kunda1 Fixed in Version => 0.16
2017-01-24 19:16 Kunda1 Resolution open => fixed
2017-01-24 19:16 Kunda1 Assigned To => Kunda1
2017-01-24 19:16 Kunda1 Tag Detached: #pending
2017-03-10 20:35 kkremitzki Status resolved => closed