View Issue Details

IDProjectCategoryView StatusLast Update
0002028PartDesignBugpublic2017-03-22 01:07
ReporterDon LawnAssigned Tokkremitzki 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformAMD Quad CoreOSWindowsOS Version7
Product Version0.14 
Target VersionFixed in Version0.17 
Summary0002028: Polar Pattern feature leaves faces missing
DescriptionWhen creating a polar pattern from a sample (gear tooth wedge),
it works fine for 2 occurrences, but leaves faces missing on occurrences, for 3 or more occurrences
Steps To ReproduceOpen the sample file "20 tooth GT2 pulley" attached.
Open the details dialog for the part "Polar Pattern" - multiple teeth"
Set the number of occurrences to "2" and tab out out of the field.
displayed part is correct.
Set the number of occurrences to "3" and tab out
The displayed part is missing side faces from the third occurrence.
Additional InformationAny number greater than three also causes the problem for all except the fist two occurrence.
TagsNo tags attached.

Relationships

related to 0002248 closedkkremitzki PartDesign Overlaps in polar patterns shouldn't always be errors 
has duplicate 0002072 closedkkremitzki PartDesign Polar pattern of slot pocketed from curved faces fails for certain number of occurrences 
has duplicate 0002246 closedkkremitzki PartDesign Polar pattern of overlapping pocket feature produces several solids (negatives of the pocket) 
has duplicate 0002637 closedkkremitzki FreeCAD Inconsistent 3D after removing operation (pocket or boolean operation) 

Activities

Don Lawn

2015-03-27 06:49

reporter  

20 tooth GT2 Pulley.FCStd (20,518 bytes)

Don Lawn

2015-03-27 07:03

reporter   ~0005947

PS. bad structure can be confirmed using the "Analyse Geometry for Errors" feature in the Part toolbox.

tanderson69

2015-03-27 16:31

developer   ~0005948

I can NOT repeat this with "OCC version: 6.8.0.oce-0.17-dev"

That being said, The pattern is creating a non-manifold condition. This is bad for boolean operations. A point on the sketch shouldn't coincide with the rotation axis.

Don Lawn

2015-03-30 05:07

reporter   ~0005957

I'll try trimming out the centre point.

normandc

2015-04-03 03:28

manager   ~0005962

Don, even if you trim out the center point, each of your occurrences will share two faces with the occurrences on both sides. This is bad practice and is a recipe for trouble. In this specific case you should use subtractive features rather than additive ones. It would be much better to pad a circle to create a cylinder, then make a cutout of a tooth using the Pocket feature. This way the polar pattern will surely succeed without errors.

Don Lawn

2015-04-04 11:34

reporter   ~0005964

Removing the centre point fixes it ok.
Normandc - thanks, subtraction would work, but would take about the same effort, which is significant because I am ultimately working up to about 150 teeth.

I must say, that I don't understand why the overlap of occurrences is such a problem. In normal construction, it is common to either get an accurate face match using sketches on faces, OR, to overlap parts and then group them into a single part. I cannot think of any other operation that has problems with overlapped parts, so I don't see why the overlap of occurrences in a polar pattern should be a problem. Each occurrence should be a complete solid with all surfaces specified, whether there is underlap of overlap. Even difficult special cases such as the origin point should be handled in some manner internally, rather than breaking the occurrences.
If the error dialog regarding overlap could be changed to give an option of accepting the overlap, then I would be able to complete the operation, and group all of the occurrences together to make a a single part from them all, using the part menu item.
Of course, there would then be the problem of the lack of a support base for the occurrences, except that this isn't really a problem if they are all to be grouped later anyway. In fact, if FreeCad detects that there is overlap, then it could simply bypass the check for a support base, and automatically group the occurrences into a single part.
This approach would result in
a) removal of two annoying errors that have to be investigated.
b) avoidance of the centre-point issue
c) no need for you to support people like me who don't understand
d) two ways to produce my gear wheel - either by addition or subtraction
e) a more intuitive option for usage.

Just my opinion - its a great product anyway.

Since there are standard workarounds (avoid the centrepoint, or use subtraction), then I am happy for you to close of downgrade this issues as you see fit. However, if you do, could I volunteer to add some text to the online help and wiki to steer others around this rock?

Don Lawn

2015-04-04 11:36

reporter   ~0005965

PS. I realise that it will be almost a mathematical impossibility to make the multiple occurrences line up face to face exactly, due to the nature of Pi. That is one reason I would naturally try to go for the overlap option, as underlap dos not make a solid piece, and would need a support base.

severoraz

2015-09-10 06:41

reporter   ~0006377

Last edited: 2015-09-10 06:42

View 2 revisions

I truly understand what you mean about overlapping being considered as a problem. I have reported the bug 0002248 to suggest that this be handled differently.

I also had reported bug 0002246 and it seems to be a duplicate of this issue.

I also found bug 0002072 to be very similar to this one; I think both bugs 0002246 and 0002072 are duplicates of 0002028 (present bug).

Kunda1

2017-01-12 14:15

manager   ~0007669

@wmayer shall i merge 0002072 & 0002246 with this ticket?

Kunda1

2017-01-28 12:00

manager   ~0008046

Linked 0002637 to this ticket as well.

jnxd

2017-03-21 19:33

developer   ~0008683

Last edited: 2017-03-21 19:39

View 2 revisions

The file indeed looks broken, but I was not able to reproduce it with PDN. See file attached. There might be some minute details left so don't close this yet.

Edit: could simply get rid of the issue by using "Part Design->Migrate" on the file posted by OP.

version:
OS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.10540 (Git)
Build type: None
Branch: master
Hash: 2c9d5e30108a2a34a7f11cfad3d9c323e5577ce1
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0



issue2028_OK.fcstd (30,876 bytes)

Issue History

Date Modified Username Field Change
2015-03-27 06:49 Don Lawn New Issue
2015-03-27 06:49 Don Lawn File Added: 20 tooth GT2 Pulley.FCStd
2015-03-27 07:03 Don Lawn Note Added: 0005947
2015-03-27 16:31 tanderson69 Note Added: 0005948
2015-03-30 05:07 Don Lawn Note Added: 0005957
2015-04-03 03:28 normandc Note Added: 0005962
2015-04-04 11:34 Don Lawn Note Added: 0005964
2015-04-04 11:36 Don Lawn Note Added: 0005965
2015-09-10 06:41 severoraz Note Added: 0006377
2015-09-10 06:42 severoraz Note Edited: 0006377 View Revisions
2017-01-12 14:12 Kunda1 Relationship added related to 0002248
2017-01-12 14:15 Kunda1 Note Added: 0007669
2017-01-12 14:15 Kunda1 Relationship added related to 0002072
2017-01-12 14:15 Kunda1 Relationship added related to 0002246
2017-01-13 22:32 Kunda1 Relationship replaced has duplicate 0002072
2017-01-13 22:32 Kunda1 Relationship replaced has duplicate 0002246
2017-01-28 11:59 Kunda1 Relationship added has duplicate 0002637
2017-01-28 12:00 Kunda1 Note Added: 0008046
2017-03-21 19:33 jnxd File Added: issue2028_OK.fcstd
2017-03-21 19:33 jnxd Note Added: 0008683
2017-03-21 19:39 jnxd Note Edited: 0008683 View Revisions
2017-03-22 01:07 kkremitzki Assigned To => kkremitzki
2017-03-22 01:07 kkremitzki Status new => closed
2017-03-22 01:07 kkremitzki Resolution open => fixed
2017-03-22 01:07 kkremitzki Fixed in Version => 0.17