View Issue Details

IDProjectCategoryView StatusLast Update
0002015SketcherBugpublic2015-12-15 13:18
ReporterriX Assigned Toabdullah  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformOSLinux x86_64OS Version3.18.6-1-ARCH
Product Version 
Target VersionFixed in Version0.16 
Summary0002015: Crash when setting equal constraint on too many elements.
DescriptionSelecting 14 or more arc elements in sketch and adding equal constraint crashes FreeCAD. The first 13 are created one by one, and when number 14 should have been set, there is a crash.
Steps To ReproduceSelect all 15 arcs in the attached sketch, press equal constraint.
TagsNo tags attached.
FreeCAD Information

Activities

riX

2015-03-20 23:03

reporter  

housing.fcstd (8,319 bytes)

riX

2015-03-20 23:09

reporter   ~0005890

Forgot version, it's:

OS: Linux
Word size: 64-bit
Version: 0.14.3702 (Git)
Branch: releases/FreeCAD-0-14
Hash: b3368125c63289ec8ce9faec2b2ae4c78d436406
Python version: 2.7.9
Qt version: 4.8.6
Coin version: 3.1.3
SoQt version: 1.5.0

abdullah

2015-08-16 09:26

manager   ~0006289

The version you are using is quite old.

I have downloaded your sketch, selected all the arcs, applied an equality constraint. It takes some time (maybe 15 seconds), but all the constraints get applied and I have no crash.

I have used one of the latest Ubuntu PPA:

OS: Ubuntu 14.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.5342 (Git)
Build type: None
Branch: master
Hash: 790714712a145bdd8370a68bbcca201ecc4ba6c4
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

My only advice would be to get a newer version of FC, as this seems fixed.

abdullah

2015-08-16 09:29

manager   ~0006290

I am closing this ticket to keep things tidy.

If you need help installing a newer version on your system feel free to open a thread in the FC user forum.

Feel free to reopen it if you want to submit any further information.

abdullah

2015-08-16 09:30

manager   ~0006291

The issue is no longer present in current PPA/master.

Issue History

Date Modified Username Field Change
2015-03-20 23:03 riX New Issue
2015-03-20 23:03 riX File Added: housing.fcstd
2015-03-20 23:09 riX Note Added: 0005890
2015-08-16 06:29 abdullah Assigned To => abdullah
2015-08-16 06:29 abdullah Status new => assigned
2015-08-16 09:26 abdullah Note Added: 0006289
2015-08-16 09:29 abdullah Note Added: 0006290
2015-08-16 09:30 abdullah Note Added: 0006291
2015-08-16 09:30 abdullah Status assigned => closed
2015-08-16 09:30 abdullah Resolution open => fixed
2015-12-15 13:18 yorik Fixed in Version => 0.16