View Issue Details

IDProjectCategoryView StatusLast Update
0002011FreeCADBugpublic2015-03-20 12:23
Reporterplgarcia Assigned Toickby  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindows 7 OS Version
Product Version0.14 
Target VersionFixed in Version0.15 
Summary0002011: Cut with an array does not work if the patterns overlay. Calculation is very long, and the result is incorrect.
DescriptionI made it minor becaus it is always possible to make different objects, then make a fusion instead using an array.
Steps To ReproduceA very simple project reproducing the problen is given
TagsNo tags attached.

Activities

plgarcia

2015-03-20 12:15

reporter  

BugFreeCad2.zip (Attachment missing)

ickby

2015-03-20 12:23

developer   ~0005881

This is expected behaviour, parts of an array should not overlap (selfintersections are not allowed). In 0.15 there is a new property in the array which allows to fuse all individual parts in it, this is intended to be used for situations as you present here.

Issue History

Date Modified Username Field Change
2015-03-20 12:15 plgarcia New Issue
2015-03-20 12:15 plgarcia File Added: BugFreeCad2.zip
2015-03-20 12:23 ickby Note Added: 0005881
2015-03-20 12:23 ickby Status new => closed
2015-03-20 12:23 ickby Assigned To => ickby
2015-03-20 12:23 ickby Resolution open => fixed
2015-03-20 12:23 ickby Fixed in Version => 0.15