View Issue Details

IDProjectCategoryView StatusLast Update
0002008FreeCADBugpublic2017-07-11 20:12
ReporterJin Assigned To 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Platformx86_64 linuxOSFedoraOS Version21
Product Version 
Target VersionFixed in Version0.17 
Summary0002008: not possible to compile because Coin3d headers are not found
DescriptionCurrent master head does not compile on Fedora 21, because the cmake scripts fail to find Coin3d includes.

I.e.:
free-cad-code/src/Gui/Utilities.cpp:27:32: fatal error: Inventor/SbMatrix.h: No such file or directory
 # include <Inventor/SbMatrix.h>


The solution is to use pkg-config on Linux systems, this will resolve problems like these. I'd fix it myself it was autotools, but after an hour of battling cmake I gave up, so I hope someone else can do it.

I can confirm, that when pasting the failed compile line (make VERBOSE=1) and manually adding the output from pkg-config Coin3 --cflags does allow to compile the sources that otherwise fail.

Please refer to http://www.cmake.org/cmake/help/v3.0/module/FindPkgConfig.html
TagsNo tags attached.
FreeCAD Information

Activities

Kunda1

2017-01-10 15:17

administrator   ~0007602

Forum thread: http://forum.freecadweb.org/viewtopic.php?f=4&t=19771

Kunda1

2017-01-10 16:44

administrator   ~0007610

According to @wmayer (in http://forum.freecadweb.org/viewtopic.php?f=4&t=19771&p=152659#p152659) a commit was made (http://github.com/FreeCAD/FreeCAD/commit/6ee243c2fa)
Therefore this ticket looks like it can be closed. Tagging #tobeclosed

Issue History

Date Modified Username Field Change
2015-03-18 20:09 Jin New Issue
2017-01-10 15:17 Kunda1 Note Added: 0007602
2017-01-10 16:44 Kunda1 Note Added: 0007610
2017-01-10 16:45 Kunda1 Tag Attached: #tobeclosed
2017-01-10 17:01 wmayer Status new => closed
2017-01-10 17:01 wmayer Resolution open => fixed
2017-01-10 17:01 wmayer Fixed in Version => 0.17
2017-07-11 20:12 Kunda1 Tag Detached: #tobeclosed