View Issue Details

IDProjectCategoryView StatusLast Update
0002007FreeCADBugpublic2015-04-10 06:10
Reportershoogen Assigned Towmayer  
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.16 
Target VersionFixed in Version 
Summary0002007: Base::Rotation::get/setYawPitchRoll uses wrong euler convention
DescriptionThe current implementation performs the rotations in the wrong order. It works like gp_Intrinsic_XYZ when it should work like gp_Intrinsic_ZYX.
Additional Informationhttp://forum.freecadweb.org/viewtopic.php?f=13&t=10111 (in German language)
TagsNo tags attached.
FreeCAD Information

Relationships

related to 0002045 closedwmayer Make Euler Rotation default or user-pref default 

Activities

wmayer

2015-03-14 19:54

administrator   ~0005874

The implementation as we have works so it's not a bug. And since we don't know who uses it already in Python or C++ it is dangerous to change the implementation because this breaks existing code.

So, it might be better to additionally offer an alternative method.

shoogen

2015-03-14 20:43

developer   ~0005875

> The implementation as we have works so it's not a bug.
It does not work as documented.

Related Changesets

FreeCAD: master 0950b330

2015-03-15 18:53:03

wmayer

Details Diff
+ issue 0002007: Base::Rotation::get/setYawPitchRoll uses wrong euler convention Affected Issues
0002007
mod - src/Base/Rotation.cpp Diff File

FreeCAD: master 16c1dbd2

2015-03-15 20:58:53

shoogen


Committer: wmayer Details Diff
document the convention used for Euler angles (XY'Z'')

in the Placement dialog and the docstrings of the Rotation python class.
fixes 0002007
Affected Issues
0002007
mod - src/Base/RotationPy.xml Diff File
mod - src/Gui/Placement.cpp Diff File
mod - src/Gui/Placement.ui Diff File

Issue History

Date Modified Username Field Change
2015-03-14 17:58 shoogen New Issue
2015-03-14 18:17 shoogen Description Updated View Revisions
2015-03-14 19:54 wmayer Note Added: 0005874
2015-03-14 20:43 shoogen Note Added: 0005875
2015-03-15 18:00 wmayer Changeset attached => FreeCAD Master master 0950b330
2015-03-21 12:40 wmayer Changeset attached => FreeCAD Master master 16c1dbd2
2015-03-21 12:40 wmayer Assigned To => wmayer
2015-03-21 12:40 wmayer Status new => closed
2015-03-21 12:40 wmayer Resolution open => fixed
2015-04-10 06:10 shoogen Relationship added related to 0002045