View Issue Details

IDProjectCategoryView StatusLast Update
0000020FreeCADFeaturepublic2016-07-23 10:45
ReporterJriegelAssigned ToJriegel 
PrioritylowSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.17 
Summary0000020: UndoRedo for Gui Elements
DescriptionImplement a Undo/Redo for all Gui Objects
TagsNo tags attached.
FreeCAD Information

Relationships

parent of 0001990 closedwmayer Undo does not work for 'toggle visibility' 
parent of 0002054 closedwmayer Undo/redo of fillet does not bring back previous visibility 
related to 0000819 closedJriegel Faces colors lost again (sorry) 
related to 0001118 closedJriegel The Undo/Redo function is broken and does sometimes not deliver the expected results. 

Activities

Jriegel

2012-09-04 13:55

administrator   ~0002340

Mhh, not likely I will do that soon, since Assambly introduce concepts
for coloring bigger models on App level.

pperisin

2012-09-04 17:17

reporter   ~0002341

It is good idea to move color to app. I was bit surprised it is in the gui. Take your time, no big deal.

Issue History

Date Modified Username Field Change
2009-09-28 15:45 Jriegel New Issue
2009-09-28 15:47 Jriegel Status new => assigned
2009-09-28 15:47 Jriegel Assigned To => Jriegel
2012-08-31 09:07 wmayer Relationship added related to 0000819
2012-09-04 13:55 Jriegel Note Added: 0002340
2012-09-04 13:56 Jriegel Priority normal => low
2012-09-04 17:17 pperisin Note Added: 0002341
2013-06-18 15:07 wmayer Relationship added related to 0001118
2015-03-03 09:29 wmayer Relationship added parent of 0001990
2016-07-23 10:44 wmayer Relationship added parent of 0002054
2016-07-23 10:45 wmayer Status assigned => closed
2016-07-23 10:45 wmayer Resolution open => fixed
2016-07-23 10:45 wmayer Fixed in Version => 0.17