View Issue Details

IDProjectCategoryView StatusLast Update
0001950DraftBugpublic2017-06-14 18:15
ReporterctjctjAssigned To 
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version14.10
Product Version0.15 
Target VersionFixed in Version0.17 
Summary0001950: If draft grid space is set to zero then drafting draw tools fail.
DescriptionClean install of 0.15 daily as of 2015/02/02
In draft workbench

If the grid spacing is set to 0.00 which seems to be a default on clean/new install when a user attempts to draw anything it generates a divide by zero exception when the mouse enters the drawing window.

Since snap to grid appears to be the default to a new user it looks like the draft workbench is broken.

Work around is to set the grid spacing to non-zero.
Steps To Reproduceclear all preferences and do a clean install.
start freecad.
Go to draft workbench.
Make new drawing.
Click on line, click in drawing window.
If report view is showing there will be an error message.
If the report view is not showing then there is no error.
OR
Can also be reproduced by going to preferences->draft workbench->snap settings
and set spacing to 0.
Additional InformationReal issue is in the UI. If the default was non-zero AND the UI did not allow grid spacing to be set to zero then the error would not occur.
Tagssnap

Relationships

related to 0001951 new Draft workbench preferences snap settings does not use "units" settings 

Activities

ickby

2015-02-04 15:33

developer   ~0005765

The default value for this setting is 1. Did you have freecad installed before? The setting files are keept between installations, maybe the wrong value was created in an older FreeCAD version.

ctjctj

2015-02-04 19:50

reporter   ~0005766

I started with apt-get install freecad freecad-doc
I then added the PPA for the dailies of freecad and have been using that since. So it could well have been a zero that came forward.

jreinhardt

2015-02-05 09:27

developer   ~0005767

The reporter uses an imperial unit scheme, could this have screwed with things?

A workaround could be to set the minimum grid spacing to something small but positive, like a nanometer.

Is the default value set in the userprefs-snap.ui file, or is there some other place that I missed?

JanneK

2015-02-07 12:05

reporter   ~0005769

Last edited: 2017-02-02 12:17

View 2 revisions

It looks like the Tracker-concept needs to be rewritten a bit.
Each tracker, like "GridTracker" should be able to decide for itself whether it is allowed to be turned on or not.

like:
def on:
  start()
  return self.started()

Also, the naming could be improved, e.g. turnOn(), turnOff()

Also # 2, it looks like "reset" is called continuously when the mouse is being moved. is this intentional?

Kunda1

2017-06-02 00:01

manager   ~0009248

@NormandC do you mind weighing in?

Kunda1

2017-06-14 12:59

manager   ~0009368

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=22938

chrisb

2017-06-14 16:17

developer   ~0009369

Issue is solved. The default grid width is set to 1mm.
Tested versions: see forum thread.

Kunda1

2017-06-14 18:15

manager   ~0009373

Fixed on both 0.16 and 0.17 per @chrisb
Labeled fix as 0.17 since 0.16 not available as tag anymore. Closing

Issue History

Date Modified Username Field Change
2015-02-04 15:00 ctjctj New Issue
2015-02-04 15:33 ickby Note Added: 0005765
2015-02-04 19:50 ctjctj Note Added: 0005766
2015-02-05 09:27 jreinhardt Note Added: 0005767
2015-02-07 12:05 JanneK Note Added: 0005769
2017-01-16 10:16 Kunda1 Project FreeCAD => Draft
2017-02-02 12:17 Kunda1 Note Edited: 0005769 View Revisions
2017-02-02 12:19 Kunda1 Steps to Reproduce Updated View Revisions
2017-05-06 11:25 Kunda1 Tag Attached: snap
2017-05-06 11:26 Kunda1 Product Version => 0.15
2017-05-06 11:27 Kunda1 Relationship added related to 0001951
2017-06-02 00:01 Kunda1 Note Added: 0009248
2017-06-14 12:59 Kunda1 Note Added: 0009368
2017-06-14 16:17 chrisb Note Added: 0009369
2017-06-14 18:15 Kunda1 Status new => closed
2017-06-14 18:15 Kunda1 Resolution open => fixed
2017-06-14 18:15 Kunda1 Fixed in Version => 0.17
2017-06-14 18:15 Kunda1 Note Added: 0009373