View Issue Details

IDProjectCategoryView StatusLast Update
0001932FreeCADBugpublic2016-08-10 16:16
ReporterDeepSOICAssigned ToDeepSOIC 
PrioritynormalSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
PlatformOSWindowsOS Version8.1
Product Version 
Target VersionFixed in Version0.17 
Summary0001932: Part revolve produces invalid solid when axis is tilted
DescriptionImagine the situation. I have a tilted rectangle (sketch) that I have made to produce a cylinder in the right place. I want to use Part Revolve because the sketch is, for example, mapped to a face of something else, but I want a separate cylinder.
So, I invoke Part Revolve, select the sketch, the line (an edge of the sketch to serve as the axis of revolution), and get an invalid solid (sometimes).
Steps To Reproduce1. Create a new sketch. Draw a tilted rectangle. Close.
2. Invoke Part Revolve. Select the sketch to revolve. Hit "Select line in 3D view" button, select an edge of the sketch. Tick "Create Solid" checkbox. Click OK.
3. Check the result. Sometimes, there will be errors like BOPAlgo SelfIntersect. Sometimes, the solid will be valid, but the cylinder will have a tiny hole in it.
Additional InformationLooks like there is a loss of precision somewhere. Maybe, the strings appearing in the UI after the axis was selected are read back with those just two decimal digits of precision.

Forum thread: http://forum.freecadweb.org/viewtopic.php?f=8&t=9471

OS: Windows 8.1
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.15.4498 +7 (Git)
Branch: sketcher-FixReversedGeoms-emulation-squashed
Hash: 3e8f7f5738b13dbfbe5b1ef87b8421a3801646b5
Python version: 2.7.8
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.7.1
Tagsrounding

Activities

DeepSOIC

2015-01-25 18:18

developer  

revolve invalid.FCStd (Attachment missing)

shoogen

2015-01-25 20:18

developer   ~0005735

the precision of the dialog has been set to two decimal places ever since it addition on 2009-10-15

tanderson69

2015-01-26 01:39

developer   ~0005736

I can confirm DeepSOIC suspicion. I hacked the dialog to ignore the edit boxes and just use the filters location and direction. That cured the problem.

DeepSOIC

2016-08-09 17:52

developer   ~0007258

fixed since commit 50af9efa9f6ef7f7f7018eb77c70013ee5147c06

Related Changesets

FreeCAD: master 50af9efa

2016-08-08 15:59:25

DeepSOIC

Details Diff
PartGui: new Revolve task dialog.

Updated to support Axis link, and Symmetric properties. Layout was
completely changed.
Affected Issues
0001932
mod - src/Mod/Part/Gui/DlgRevolution.cpp Diff File
mod - src/Mod/Part/Gui/DlgRevolution.h Diff File
mod - src/Mod/Part/Gui/DlgRevolution.ui Diff File

Issue History

Date Modified Username Field Change
2015-01-25 18:18 DeepSOIC New Issue
2015-01-25 18:18 DeepSOIC File Added: revolve invalid.FCStd
2015-01-25 19:43 shoogen Relationship added related to 0001909
2015-01-25 19:55 shoogen Tag Attached: rounding
2015-01-25 20:18 shoogen Note Added: 0005735
2015-01-25 20:29 shoogen Relationship deleted related to 0001909
2015-01-26 01:39 tanderson69 Note Added: 0005736
2016-08-09 17:52 DeepSOIC Note Added: 0007258
2016-08-10 16:13 wmayer Changeset attached => FreeCAD Master master 50af9efa
2016-08-10 16:16 wmayer Status new => closed
2016-08-10 16:16 wmayer Assigned To => DeepSOIC
2016-08-10 16:16 wmayer Resolution open => fixed
2016-08-10 16:16 wmayer Fixed in Version => 0.17