View Issue Details

IDProjectCategoryView StatusLast Update
0001898FreeCADBugpublic2017-01-11 13:23
ReporterBibiAssigned To 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
PlatformMac and WindowsOSMac and WindowsOS Version10.7 and 7
Product Version0.14 
Target Version0.15Fixed in Version0.16 
Summary0001898: Drawing workbench draws cylinder in orthographic projection wrong
DescriptionSee explanation here:
http://forum.freecadweb.org/viewtopic.php?f=3&t=9222

Same results on Mac and Windows and both versions: 0.14 and 0.15.
Steps To ReproduceSee here:
http://forum.freecadweb.org/viewtopic.php?f=3&t=9222
TagsNo tags attached.

Relationships

related to 0001899 closedkkremitzki Drawing discretize in DrawingExport::printGeneric 
related to 0001912 closedwmayer FreeCAD Drawing Workbench Not Displaying Views of Cylindrical Parts. 

Activities

shoogen

2015-01-06 12:16

developer   ~0005533

We could tweak the settings for the BSpline approximation once or we could make them available as Parameters in the DrawingGui preferences.

wmayer

2015-01-10 16:53

administrator   ~0005609

Allowing to use different values for the approximation is troublesome because you will always find an example where the approximation works but badly fails for another one.

IMO, it might be better to have a function that checks how close the spline is to a circle and if it's close enough compute an exact circle and use this instead.

Therefore the spline can be discretized into three points first so that the center of the circle can be computed. Then the spline can be discretized into e.g. 30 points and if all of them have a distance to the center within a certain tolerance we can consider the spline as a circle.

normandc

2015-01-11 22:30

manager   ~0005621

Please see http://forum.freecadweb.org/viewtopic.php?f=3&t=9289
This fix may have caused a new problem.

wmayer

2015-01-12 00:46

administrator   ~0005627

Caused a regression when a line is represented as a b-spline curve. Then the circle check failed because the curvature center cannot be computed.

shoogen

2015-02-10 12:13

developer   ~0005779

Last edited: 2015-02-10 15:28

View 2 revisions

is responsible for the reversed arcs.

shoogen

2015-02-10 15:30

developer   ~0005782

changed the severity to blocker, as this created a regression which is trivial to workaround for the 0.15 release.
git://github.com/5263/FreeCAD bugfix-drawingarcs

Kunda1

2017-01-11 01:48

administrator   ~0007620

Last edited: 2017-01-11 01:48

View 2 revisions

According to @NormandC in http://forum.freecadweb.org/viewtopic.php?f=3&t=9222&p=152696#p152696
The problem appears to be fixed in

OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6706 (Git)
Build type: Release
Branch: releases/FreeCAD-0-16
Hash: f86a4e411ff7848dea98d7242f43b7774bee8fa0
Python version: 2.7.8
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Forcing a recompute fixes the Drawing views.


Related Changesets

FreeCAD: master 0a31beba

2015-01-11 01:46:31

wmayer

Details Diff
+ fixes 0001898: Drawing workbench draws cylinder in orthographic projection wrong Affected Issues
0001898
mod - src/Mod/Drawing/App/DrawingExport.cpp Diff File
mod - src/Mod/Drawing/App/DrawingExport.h Diff File

Issue History

Date Modified Username Field Change
2015-01-06 05:44 Bibi New Issue
2015-01-06 12:16 shoogen Note Added: 0005533
2015-01-06 15:27 shoogen Relationship added related to 0001899
2015-01-10 16:53 wmayer Note Added: 0005609
2015-01-11 01:09 wmayer Changeset attached => FreeCAD Master master 0a31beba
2015-01-11 01:09 wmayer Assigned To => wmayer
2015-01-11 01:09 wmayer Status new => closed
2015-01-11 01:09 wmayer Resolution open => fixed
2015-01-11 22:30 normandc Note Added: 0005621
2015-01-11 22:30 normandc Status closed => feedback
2015-01-11 22:30 normandc Resolution fixed => reopened
2015-01-12 00:46 wmayer Note Added: 0005627
2015-01-12 00:46 wmayer Status feedback => closed
2015-01-12 00:46 wmayer Resolution reopened => fixed
2015-01-12 00:46 wmayer Fixed in Version => 0.15
2015-01-25 00:47 shoogen Relationship added related to 0001912
2015-02-10 12:13 shoogen Note Added: 0005779
2015-02-10 12:13 shoogen Status closed => feedback
2015-02-10 12:13 shoogen Resolution fixed => reopened
2015-02-10 12:13 shoogen Severity major => block
2015-02-10 12:14 shoogen Fixed in Version 0.15 =>
2015-02-10 12:14 shoogen Target Version => 0.15
2015-02-10 15:28 shoogen Note Edited: 0005779 View Revisions
2015-02-10 15:30 shoogen Note Added: 0005782
2015-02-10 15:30 shoogen Status feedback => assigned
2016-07-28 17:21 wmayer Assigned To wmayer =>
2017-01-11 01:48 Kunda1 Note Added: 0007620
2017-01-11 01:48 Kunda1 Note Edited: 0007620 View Revisions
2017-01-11 13:23 wmayer Status assigned => closed
2017-01-11 13:23 wmayer Resolution reopened => fixed
2017-01-11 13:23 wmayer Fixed in Version => 0.16