View Issue Details

IDProjectCategoryView StatusLast Update
0001879DraftBugpublic2014-12-29 20:59
Reportermghansen256 Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.14 
Target VersionFixed in Version 
Summary0001879: Draft->move behaves strangely when snap to working plane is enabled but working plane is 'none'
DescriptionWhen the working plane is set to 'none' but draft snapping includes the working plane, the snapping while doing for example a "draft->move" seems random. IMHO when the working plane is set to none, the snapping system should ignore the working plane snap option - since snapping is otherwise kind of random, it can take the user a long time to figure out the problem ;-)
Steps To Reproduce1. Set draft working plane to none, enable snapping to the working plane.
2. Start moving an object and select the starting point.
3. Try putting the object somewhere, snapping will be random.
Additional InformationOS: Ubuntu 14.10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.15.4343 (Git)
Branch: master
Hash: 16a8965038f59fb7dc7d751137dc016999e5728d
Python version: 2.7.8
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.7.0
TagsNo tags attached.
FreeCAD Information

Activities

mghansen256

2014-12-27 21:02

reporter  

mghansen256

2014-12-27 21:04

reporter   ~0005452

Screenshot shows me trying to move the cylinder on the left (starting point is top center of the cylinder) to the right hand side of the box, snapping to the corner. However, as the UI indicates, the cylinder's top center will not be placed at the corner.

yorik

2014-12-28 00:29

administrator   ~0005456

This is IMHO not a bug. There is always a working plane, which, when it is set to None, adapts to the current view. If you press the "snap to working plane" button, you will indeed snap to that temporary working plane.

Maybe what we need to do is change the word "None" for something more meaningful ("Auto" maybe?)

Related Changesets

FreeCAD: master 638fa8ba

2014-12-29 20:54:04

yorik

Details Diff
Draft: Changed working plane button text to Auto - fixes 0001879 Affected Issues
0001879
mod - src/Mod/Draft/DraftGui.py Diff File
mod - src/Mod/Draft/DraftTools.py Diff File

Issue History

Date Modified Username Field Change
2014-12-27 21:02 mghansen256 New Issue
2014-12-27 21:02 mghansen256 File Added: freecad-2014-12-27-draft-move.png
2014-12-27 21:04 mghansen256 Note Added: 0005452
2014-12-28 00:29 yorik Note Added: 0005456
2014-12-28 00:29 yorik Assigned To => yorik
2014-12-28 00:29 yorik Status new => assigned
2014-12-29 20:59 yorik Changeset attached => FreeCAD Master master 638fa8ba
2014-12-29 20:59 yorik Status assigned => closed
2014-12-29 20:59 yorik Resolution open => fixed