View Issue Details

IDProjectCategoryView StatusLast Update
0001878FreeCADBugpublic2014-12-28 17:40
Reportertanderson69 Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformamd64OSKubuntuOS Version 13.10
Product Version0.15 
Target Version0.15Fixed in Version 
Summary0001878: model refine exception
Descriptionmodel refine fails with exception due to a null gp_Vec.
Steps To ReproduceLoad attached file and run model refine.
Additional Informationsee backtrace
TagsNo tags attached.
FreeCAD Information

Activities

tanderson69

2014-12-27 16:15

developer  

cut003_bugReport.fcstd (Attachment missing)

tanderson69

2014-12-27 16:16

developer  

cut003_backtrace.txt (Attachment missing)

wmayer

2014-12-28 16:55

administrator   ~0005457

The problem is inside the function "wireEncirclesAxis" in the else block which starts with this comment:
// Linearize the edge. Idea taken from ShapeAnalysis.cxx ShapeAnalysis::TotCross2D()


The problem is that "dv" is the null vector because "begin" and "pend" are identical. This happens in the second iteration "j=2".

Related Changesets

FreeCAD: master e329cb5c

2014-12-28 18:10:02

wmayer

Details Diff
+ fixes 0001878: model refine exception Affected Issues
0001878
mod - src/Mod/Part/App/modelRefine.cpp Diff File

Issue History

Date Modified Username Field Change
2014-12-27 16:15 tanderson69 New Issue
2014-12-27 16:15 tanderson69 Status new => assigned
2014-12-27 16:15 tanderson69 Assigned To => jrheinlaender
2014-12-27 16:15 tanderson69 File Added: cut003_bugReport.fcstd
2014-12-27 16:16 tanderson69 File Added: cut003_backtrace.txt
2014-12-28 16:55 wmayer Note Added: 0005457
2014-12-28 17:40 wmayer Changeset attached => FreeCAD Master master e329cb5c
2014-12-28 17:40 wmayer Assigned To jrheinlaender => wmayer
2014-12-28 17:40 wmayer Status assigned => closed
2014-12-28 17:40 wmayer Resolution open => fixed