View Issue Details

IDProjectCategoryView StatusLast Update
0000186FreeCADFeaturepublic2010-11-06 18:28
Reporterpperisin Assigned Toyorik  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.11 
Summary0000186: Dimension - edit Value
DescriptionI would like to be able to enter value inside dimension, so that the length of dimension (and constrained line) is updated - for sketcher.
TagsNo tags attached.
FreeCAD Information

Activities

yorik

2010-10-27 10:36

administrator   ~0000391

I'll add this to the Draft dimension

yorik

2010-11-06 18:28

administrator   ~0000400

Added to Draft dimensions in r3700. There is now a "text override" property, that can be used to specify alternative text to display on the dimension. Any "<>" characters found in that text will be replaced by the dimension length, the same way as autocad.

Now I think what the original reporter wanted is to be able to edit/add the length of an edge directly in the sketcher, which is possible already:

- place a length constraint on a segment
- double-click on that constraint in the task panel
- edit the desired length
- move one of the points so the solver knows how to apply the new length

I'll close this feature request because it works already, feel free to reopen if something is wrong.

Issue History

Date Modified Username Field Change
2010-10-27 08:38 pperisin New Issue
2010-10-27 10:36 yorik Note Added: 0000391
2010-10-27 10:36 yorik Status new => assigned
2010-10-27 10:36 yorik Assigned To => yorik
2010-11-06 18:28 yorik Note Added: 0000400
2010-11-06 18:28 yorik Status assigned => closed
2010-11-06 18:28 yorik Resolution open => fixed
2010-11-06 18:28 yorik Fixed in Version => 0.11