View Issue Details

IDProjectCategoryView StatusLast Update
0000184FreeCADFeaturepublic2011-03-08 19:38
Reporterpperisin Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.10 
Target VersionFixed in Version0.12 
Summary0000184: Export color information to STEP (AP214)
DescriptionI thing that right now FreeCAD is able to export to STEP AP203, which does not support color information. AP214 version of STEP has support for colors. Could you make FreeCAD support this version of STEP
Additional InformationI know that Altium (PCB Design software) uses OpenCascade, and it has STEP support for colors (AP214). Many of people who use Altium could use FreeCAD for creating 3D models of electronic components and use them in Altium (LINK: http://valhalla.altium.com/videos/Winter_10_Featurette/t-01398-768x432_708kbit_15fps.mp4). With few more stuff I think many of them could be convinced to work with FreeCAD, since precision and modeling of electronic components is not so complex and it does not need big precision.

Regards
TagsNo tags attached.
FreeCAD Information

Relationships

related to 0000072 closedJriegel Use color information from STEP format 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2010-10-27 05:29 pperisin New Issue
2010-10-27 07:17 wmayer Relationship added related to 0000072
2011-03-08 19:38 Jriegel Status new => closed
2011-03-08 19:38 Jriegel Resolution open => fixed
2011-03-08 19:38 Jriegel Fixed in Version => 0.12