View Issue Details

IDProjectCategoryView StatusLast Update
0001828SketcherBugpublic2014-11-17 18:50
ReporterDeepSOICAssigned Towmayer 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
PlatformPCOSAnyOS Version
Product Version0.14 
Target VersionFixed in Version0.15 
Summary0001828: Sketcher slot has broken constraints after creation sometimes
DescriptionWhen creating a Slot shape on a sketch, the resulting geometry sometimes confuses the solver. Symptoms vary: approx 1 of 10 slots drawn is reported to have more than 4 degrees of freedom (I've seen numbers as high as 8), and very occasionally, the slot is not movable by mouse.
Steps To Reproduce1. create a new sketch
2. click the slot tool on the toolbar and arbitrarily draw a slot with the mouse.
3. look at the number of reported degrees of freedom. 4 is the correct number, the bug is vhen it get higher than 4.
4. (if dof=4) delete the slot and draw a new one. Keep doing this until you get dof>4
5. (for fun!) drag the slot by one of the tangency points and observe the broken coincidence (sometimes). The coincidence is typically restored on the release of the mouse button, and dof becomes the normal =4.
Additional InformationThe slot typically becomes normal after being moved e.g. by mouse.
A guess for the cause:
Tangency of line to arc and coincident's Y part should appear redundant in the Jacobian matrix. If so I wonder why isn't it reported.

OS: Windows 8.1
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.15.4204 (Git)
Branch: Ellipse_final_rebased
Hash: bad7aa30b51d651468706560cf4505b339db37c3
Python version: 2.7.5
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.7.0

OS: Windows 7 (8.1 actually!)
Word size: 64-bit
Version: 0.14.3700 (Git)
Branch: releases/FreeCAD-0-14
Hash: 32f5aae0a64333ec8d5d160dbc46e690510c8fe1
Python version: 2.7.6
Qt version: 4.8.5
Coin version: 4.0.0a
SoQt version: 1.6.0a
OCC version: 6.6.0

(quick61's, probably:)
OS: Ubuntu 14.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.15.4202 (Git)
Branch: Ellipse_final_rebased
Hash: 7f9d89c7edae52afbb02b1c55cdc4e12e9669b48
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.7.1
TagsNo tags attached.

Activities

DeepSOIC

2014-11-15 16:12

developer   ~0005318

Corresponding forum thread:
http://forum.freecadweb.org/viewtopic.php?f=8&t=8433

DeepSOIC

2014-11-16 23:04

developer   ~0005325

Fixed =)

Related Changesets

FreeCAD: master 86a1757c

2014-11-16 20:45:13

DeepSOIC


Committer: wmayer Details Diff
Sketcher: Slot: proper tangent constraints

Endpoint-to-endpoint tangency is applied now instead of
tangency+coincident.
Fixes issue 0001828 ( http://freecadweb.org/tracker/view.php?id=0001828
)
Affected Issues
0001828
mod - src/Mod/Sketcher/Gui/CommandCreateGeo.cpp Diff File

Issue History

Date Modified Username Field Change
2014-11-15 16:11 DeepSOIC New Issue
2014-11-15 16:12 DeepSOIC Note Added: 0005318
2014-11-16 22:41 wmayer Changeset attached => FreeCAD Master master 86a1757c
2014-11-16 23:04 DeepSOIC Note Added: 0005325
2014-11-17 18:50 wmayer Status new => closed
2014-11-17 18:50 wmayer Assigned To => wmayer
2014-11-17 18:50 wmayer Resolution open => fixed
2014-11-17 18:50 wmayer Fixed in Version => 0.15