View Issue Details

IDProjectCategoryView StatusLast Update
0001825FreeCADBugpublic2014-12-29 21:19
ReporterlanciauxAssigned Toyorik 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version 
Target VersionFixed in Version 
Summary0001825: DRAFT - COTATION command - No way to have dimension of a radius, a circle or curved vertex
DescriptionBy using DRAFT Cotation command with ALT pressed to accomodate radius/curved dimensions, it fails with this message (close to problem of survey for vertex)

Indiquez le premier point :

Traceback (most recent call last):
  File "/usr/local/Mod/Arch/ArchCommands.py", line 654, in clearSelection
    self.callback(True)
  File "/usr/local/Mod/Arch/ArchCommands.py", line 681, in survey
    FreeCAD.ActiveDocument.removeObject(label)
<class 'Base.FreeCADError'>: No document object found with name 'surveyLabel'
Traceback (most recent call last):
  File "/usr/local/Mod/Arch/ArchCommands.py", line 650, in addSelection
    self.callback(True)
  File "/usr/local/Mod/Arch/ArchCommands.py", line 754, in survey
    t = t.encode("utf8").getUserPreferred()[0]
<type 'exceptions.AttributeError'>: 'Base.Quantity' object has no attribute 'encode'
TagsNo tags attached.

Relationships

duplicate of 0001821 closedyorik ASCII - ARCH SURVEY - Modification 5912342e failed on 32 bits SUSE 12.3 or 13.1 

Activities

yorik

2014-11-11 18:36

administrator   ~0005304

This is -provisorily at least, there is controversy going on :) - already fixed by issue 0001821

lanciaux

2014-11-11 20:30

reporter   ~0005306

I do not agree with you 1821 has fixed (checked it already) 2d and 3d survey but 1d is having exception because there is some property missing. Do a trial.

yours

Ludovic (Belgium)

yorik

2014-11-11 22:13

administrator   ~0005307

Ah sorry, my bad... Indeed there was still a defect. It should be fixed now.

lanciaux

2014-11-12 21:33

reporter   ~0005308

Last edited: 2014-11-12 21:34

View 2 revisions

Hello,

this has fixed lengths but there are something that is still breakable;

as there is at least 2 "t ... without .decode("utf8")" (lines 756 & 762)

Maybe others but not yet discovered !


Sorry

Ludovic (Belgium)



Traceback (most recent call last):
  File "/usr/local/Mod/Arch/ArchCommands.py", line 660, in addSelection
    self.callback(True)
  File "/usr/local/Mod/Arch/ArchCommands.py", line 767, in survey
    FreeCAD.Console.PrintMessage("Object: " + n + ", Element: " + el + ", Length: " + t + "\n")
<type 'exceptions.UnicodeDecodeError'>: 'ascii' codec can't decode byte 0xc2 in position 1: ordinal not in range(128)

Related Changesets

FreeCAD: master c07d2ad9

2014-11-11 23:11:31

yorik

Details Diff
Draft - small (provisory) encoding fix - fixes 0001825 Affected Issues
0001825
mod - src/Mod/Arch/ArchCommands.py Diff File

FreeCAD: master 2f78c021

2014-12-29 21:54:33

yorik

Details Diff
Arch: Fixed encodings in Survey - fixes 0001825 Affected Issues
0001825
mod - src/Mod/Arch/ArchCommands.py Diff File

Issue History

Date Modified Username Field Change
2014-11-11 17:01 lanciaux New Issue
2014-11-11 18:36 yorik Note Added: 0005304
2014-11-11 18:37 yorik Relationship added child of 0001821
2014-11-11 18:37 yorik Relationship deleted child of 0001821
2014-11-11 18:37 yorik Relationship added duplicate of 0001821
2014-11-11 18:38 yorik Status new => closed
2014-11-11 18:38 yorik Assigned To => yorik
2014-11-11 18:38 yorik Resolution open => duplicate
2014-11-11 20:30 lanciaux Note Added: 0005306
2014-11-11 20:30 lanciaux Status closed => feedback
2014-11-11 20:30 lanciaux Resolution duplicate => reopened
2014-11-11 22:13 yorik Note Added: 0005307
2014-11-12 00:01 yorik Changeset attached => FreeCAD Master master c07d2ad9
2014-11-12 00:01 yorik Status feedback => closed
2014-11-12 21:33 lanciaux Note Added: 0005308
2014-11-12 21:33 lanciaux Status closed => feedback
2014-11-12 21:34 lanciaux Note Edited: 0005308 View Revisions
2014-12-29 21:19 yorik Changeset attached => FreeCAD Master master 2f78c021
2014-12-29 21:19 yorik Status feedback => closed