View Issue Details

IDProjectCategoryView StatusLast Update
0001769FreeCADBugpublic2014-12-04 13:40
ReporterTJAssigned Towmayer 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSWindowsOS Version7
Product Version0.14 
Target VersionFixed in Version0.15 
Summary0001769: Models don't load as solids in Sprutcam
DescriptionWhen I create a model and save it as freecad or iges the units seem to get mixed up. The faces of a cube will be the correct size but the location will be wrong when loaded into SprutCam. The outlying faces are 10 inches from the origin but are only 10mm in size. It appears the units have been mixed or assumptions about the units have been made. Sprutcam loads freecad files directly but both freecad and freecad made iges files display this issue. Other cad softwares don't show this issue in Sprutcam.
Steps To ReproduceCreate the default 10mm cube and save as iges.
Load into Sprutcam and enjoy an exploded view. (See included screen shot.)
TagsIGES

Activities

TJ

2014-09-30 14:07

reporter  

SprutCube.PNG (Attachment missing)

quick61

2014-10-04 19:48

reporter   ~0005180

Last edited: 2014-10-04 19:51

View 2 revisions

Exporting the Cube in IGES format, then opening that IGES file in FreeCAD produces SelfInteresct errors with every edge and vertex of the cube, and object is not a solid or shell, just a compound of self intersecting edges and vertexes of faces.

I see SprutCAD uses STEP format as well. I would recommend using that format until IGES is working properly.

This is with both FreeCAD 0.14 Release (3705) and -

OS: Kubuntu 14.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.15.4097 (Git)
Branch: master
Hash: 4de77a921a7bf5f756063d08bc4b1341d04ae5e6
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.7.1 (OCE 0.17 dev)

TJ

2014-10-06 21:04

reporter   ~0005199

The STEP format produces the same error in SprutCam.

wmayer

2014-10-18 13:15

administrator   ~0005241

I don't have this problem.

Since you said it also happens with STEP format I tried a different CAD application,
VariCAD Viewer and there everything looks fine there. Also when loading the same cube into FreeCAD the geometry checker doesn't report any problems.

So, either it's a problem with the OCC/OCE version or SprutCAM is wrong, i.e. that it maybe doesn't support a certain format of IGES or STEP.

My OCC version: 6.6.0 under Windows

quick61

2014-10-20 22:16

reporter   ~0005244

TJ might want to try entering -

Part.setStaticValue("write.iges.brep.mode", 1)

into the python console before export to IGES.


FreeCAD Forum reference - http://forum.freecadweb.org/viewtopic.php?f=3&t=8100#p66420

TJ

2014-10-22 16:08

reporter   ~0005247

Last edited: 2014-10-22 16:16

View 2 revisions

Hi Quick61,
Strangely that did fix the problem. I'm not sure what that does but it did work for this. The problem still occurs with the FCStd files though.

How can this be made a standard command when exporting iges.

 Thanks!!

quick61

2014-10-22 19:36

reporter   ~0005248

Last edited: 2014-10-22 19:50

View 2 revisions

The next post below the FreeCAD forum post that is referenced above, I asked if this should be made an option in the Export function and I do not know of any further thoughts on this. This could be wrapped easy enough in a Macro with toolbar shortcut, which would work well until a more permanent solution comes.

We would want this to be an option, as this does not seem to work when used on 2D Draft elements, as the now default method does. Perhaps wmayer may want to close this now and we can open a feature request for the option. Export for IGES 2D and IGES 3D Solid.

wmayer

2014-10-29 09:30

administrator   ~0005261

The Part settings page has been split into three pages now. Two of them does the handling of IGES and STEP export. On the IGES settings page there is a check box "Enable B-REP mode" which you have to activate.

And also for every program start this settings is used to enable or disable the iges.brep.mode.

Related Changesets

FreeCAD: master c67f3261

2014-10-28 19:27:23

wmayer

Details Diff
+ split STEP and IGES settings into separate pages, handle Brep mode of IGES format Affected Issues
0001769
mod - src/Mod/Part/App/AppPart.cpp Diff File
mod - src/Mod/Part/Gui/AppPartGui.cpp Diff File
mod - src/Mod/Part/Gui/CMakeLists.txt Diff File
add - src/Mod/Part/Gui/DlgImportExportIges.ui Diff File
add - src/Mod/Part/Gui/DlgImportExportStep.ui Diff File
mod - src/Mod/Part/Gui/DlgSettingsGeneral.cpp Diff File
mod - src/Mod/Part/Gui/DlgSettingsGeneral.h Diff File
mod - src/Mod/Part/Gui/DlgSettingsGeneral.ui Diff File

Issue History

Date Modified Username Field Change
2014-09-30 14:07 TJ New Issue
2014-09-30 14:07 TJ File Added: SprutCube.PNG
2014-10-04 16:16 shoogen Tag Attached: IGES
2014-10-04 19:48 quick61 Note Added: 0005180
2014-10-04 19:51 quick61 Note Edited: 0005180 View Revisions
2014-10-06 21:04 TJ Note Added: 0005199
2014-10-18 13:15 wmayer Note Added: 0005241
2014-10-20 22:16 quick61 Note Added: 0005244
2014-10-22 16:08 TJ Note Added: 0005247
2014-10-22 16:16 TJ Note Edited: 0005247 View Revisions
2014-10-22 19:36 quick61 Note Added: 0005248
2014-10-22 19:50 quick61 Note Edited: 0005248 View Revisions
2014-10-29 09:26 wmayer Changeset attached => FreeCAD Master master c67f3261
2014-10-29 09:30 wmayer Note Added: 0005261
2014-10-29 09:30 wmayer Status new => resolved
2014-10-29 09:30 wmayer Fixed in Version => 0.15
2014-10-29 09:30 wmayer Resolution open => fixed
2014-10-29 09:30 wmayer Assigned To => wmayer
2014-12-04 13:40 wmayer Status resolved => closed