View Issue Details

IDProjectCategoryView StatusLast Update
0001750FreeCADBugpublic2017-01-15 02:20
ReportermarshgAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version12.04
Product Version 
Target VersionFixed in Version0.15 
Summary0001750: install update from daily build fails, dpkg aborts
Descriptiondpkg throws an error when running the python install script for freecad.
Steps To Reproduce1. start update-manger, or download the daily build .deb for Ubuntu 12.04
2. Install updates or use dpkg -i <package.deb>
Additional InformationEXCERPT FROM DPKG INSTALL:

Setting up freecad (0.15+git201409131801~ubuntu12.04.1) ...
Sorry: IndentationError: ('expected an indented block', ('/usr/lib/freecad/Mod/Arch/ArchEquipment.py', 67, 6, ' if placement:\n'))
dpkg: error processing freecad (--configure):
 subprocess installed post-installation script returned error exit status 101
...
Errors were encountered while processing:
 freecad
Error in function:

SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)
Setting up freecad (0.15+git201409131801~ubuntu12.04.1) ...
Sorry: IndentationError: ('expected an indented block', ('/usr/lib/freecad/Mod/Arch/ArchEquipment.py', 67, 6, ' if placement:\n'))
dpkg: error processing freecad (--configure):
 subprocess installed post-installation script returned error exit status 101
Processing triggers for menu ...
Errors were encountered while processing:
 freecad
TagsNo tags attached.

Activities

yorik

2014-09-16 19:34

administrator   ~0005108

What has that to do with the original problem shoogen?
Also the original problem is fixed already.

shoogen

2014-09-17 07:33

developer   ~0005110

Last edited: 2014-09-17 07:52

View 2 revisions

I tried to reproduce the problem an found errors mentioned above. (I'm sorry i got my paths wrong. I don't know where those files came from)
I noticed that i could not reproduce the original problem and attached the respective commit to this ticked.

yorik

2014-09-17 14:39

administrator   ~0005116

This is interesting, I had never noticed these Ifc files in the Import module... They are apparently not used...

Related Changesets

FreeCAD: master a0e461a9

2014-09-13 23:23:35

yorik

Details Diff
Arch: minor bugfix Affected Issues
0001750
mod - src/Mod/Arch/ArchEquipment.py Diff File

Issue History

Date Modified Username Field Change
2014-09-16 16:14 marshg New Issue
2014-09-16 16:23 shoogen Tag Attached: python compileall
2014-09-16 16:36 shoogen Changeset attached => FreeCAD Master master a0e461a9
2014-09-16 19:34 yorik Note Added: 0005108
2014-09-17 07:33 shoogen Note Added: 0005110
2014-09-17 07:52 shoogen Note Edited: 0005110 View Revisions
2014-09-17 07:53 shoogen Status new => closed
2014-09-17 07:53 shoogen Resolution open => fixed
2014-09-17 07:53 shoogen Fixed in Version => 0.15
2014-09-17 14:39 yorik Note Added: 0005116
2017-01-15 02:20 Kunda1 Tag Detached: python compileall