View Issue Details

IDProjectCategoryView StatusLast Update
0001735FreeCADBugpublic2014-10-17 21:21
Reporterjr222 Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSWindows 7 64xOS Version6.1.7601
Product Version0.14 
Target VersionFixed in Version0.15 
Summary0001735: Ellipsoids visibility problems
DescriptionEllipsoids (created via Part>Primitives>Create Primitive...) do not recolor to yellow when selected.

The appearance / "Display Properties" of the ellipsoids cannot be changed either using the Right-Click on the object name + Appearance (Display Properties window).
Steps To ReproducePart 1
1. Create an ellipsoid using created via Part>Primitives>Create Primitive..., press the "Create" button... it is fine to just make the default ellipsoid
2. Select it using the mouse pointer
3. Expected result would be to see it change color when selected

Part 2
4. Select the ellipsoid in the tree within the combo view
5. Right click the ellipsoid
6. Select "Appearance" from the menu
7. Change color, transparency, anything, and it won't work
Additional InformationI am running the newest 64x version of Freecad. Here is the copy and paste of the "About Freecad" window, if it may help:

OS: Windows 7
Word size: 64-bit
Version: 0.14.3700 (Git)
Branch: releases/FreeCAD-0-14
Hash: 32f5aae0a64333ec8d5d160dbc46e690510c8fe1
Python version: 2.7.6
Qt version: 4.8.5
Coin version: 4.0.0a
SoQt version: 1.6.0a
OCC version: 6.6.0
TagsNo tags attached.
FreeCAD Information

Activities

normandc

2014-09-20 17:50

manager   ~0005136

I confirm this on FreeCAD version and platform below.

In fact, the ellipsoid object is not selectable at all in the 3D view.

OS: Ubuntu 14.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.15.4052 (Git)
Branch: master
Hash: 6561b99347a53fab1fbc5b480690826f70bc06e9
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
SoQt version: 1.6.0a
OCC version: 6.7.1

shoogen

2014-09-20 18:09

developer   ~0005139

how about using the generic viewprovider

diff --git a/src/Mod/Part/Gui/ViewProvider.cpp b/src/Mod/Part/Gui/ViewProvider.c
pp
index bf7acf3..96a5f8b 100644
--- a/src/Mod/Part/Gui/ViewProvider.cpp
+++ b/src/Mod/Part/Gui/ViewProvider.cpp
@@ -1165,21 +1165,6 @@ void ViewProviderEllipsoid::updateData(const App::Propert
y* prop)
         if (cShape.IsNull())
             return;
         App::DocumentObject* object = this->getObject();
- if (object && object->isDerivedFrom(Part::Ellipsoid::getClassTypeId()))
 {
- double angle1 = static_cast<Part::Ellipsoid*>(object)->Angle1.getVa
lue();
- double angle2 = static_cast<Part::Ellipsoid*>(object)->Angle2.getVa
lue();
- double angle3 = static_cast<Part::Ellipsoid*>(object)->Angle3.getVa
lue();
- float radius1 = static_cast<Part::Ellipsoid*>(object)->Radius1.getV
alue();
- float radius2 = static_cast<Part::Ellipsoid*>(object)->Radius2.getV
alue();
- if (angle1 == -90.0 && angle2 == 90.0 && angle3 == 360.0) {
- float scale = radius1/radius2;
- pScaling->scaleFactor.setValue(1,1,scale);
- pSphere->radius.setValue(radius2);
- FaceRoot->addChild(pScaling);
- FaceRoot->addChild(pSphere);
- return; // ok, done
- }
- }

         // if not a full ellipsoid do it the general way
         ViewProviderPartBase::updateData(prop);

wmayer

2014-09-20 19:04

administrator   ~0005140

The reason for having a special view provider was because of some tessellation problems of OCC at that time. Maybe things work better now and we can switch back to the generic one.

wmayer

2014-10-17 11:55

administrator   ~0005225

git show dd392ef

Related Changesets

FreeCAD: master dd392efe

2014-10-16 19:36:54

wmayer

Details Diff
+ fixes 0001735: Ellipsoids visibility problems Affected Issues
0001735
mod - src/Mod/Part/Gui/ViewProvider.cpp Diff File
mod - src/Mod/Part/Gui/ViewProvider.h Diff File
mod - src/Mod/Part/Gui/ViewProviderSphereParametric.cpp Diff File
mod - src/Mod/Part/Gui/ViewProviderSphereParametric.h Diff File

Issue History

Date Modified Username Field Change
2014-09-06 11:09 jr222 New Issue
2014-09-20 17:50 normandc Note Added: 0005136
2014-09-20 18:09 shoogen Note Added: 0005139
2014-09-20 19:04 wmayer Note Added: 0005140
2014-10-17 11:55 wmayer Note Added: 0005225
2014-10-17 11:55 wmayer Status new => closed
2014-10-17 11:55 wmayer Assigned To => wmayer
2014-10-17 11:55 wmayer Resolution open => fixed
2014-10-17 11:55 wmayer Fixed in Version => 0.15
2014-10-17 21:21 wmayer Changeset attached => FreeCAD Master master dd392efe