View Issue Details

IDProjectCategoryView StatusLast Update
0001734SketcherBugpublic2017-12-12 21:47
ReportermiscjunkAssigned Toabdullah 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSWindowsOS Version7
Product Version0.14 
Target Version0.17Fixed in Version0.17 
Summary0001734: Constraints evaluated incorrectly while dragging a point with the mouse
DescriptionDragging a point constrained to an arc in an under-constrained sketch sometimes results in the point moving around erratically - being forced to a position not being pointed to by the mouse. I have confirmed this is not due to dragging the point to an invalid location - since when you release the point and re-drag it to the same location, it works.
Steps To Reproduce1. Open the attached file.
2. Drag one of the points on the 45deg lines which are constrained to the inner circle (see image: http://i.imgur.com/af2ZKn2.png) - around the circumference of the inner circle.
3. As the point is dragged around the inner circle, the drawing changes based on the constraints. However, at certain places around the circumference the point being dragged erratically moves to another point on the circumference not being pointed to by the pointer. I've confirmed that it is not a matter of those locations to which the point is being dragged to as being invalid constraints. If you release the mouse, and re-drag the point to the same location, it works.
Additional InformationOS: Windows 7
Word size: 32-bit
Version: 0.14.3700 (Git)
Branch: releases/FreeCAD-0-14
Hash: 32f5aae0a64333ec8d5d160dbc46e690510c8fe1
Python version: 2.6.2
Qt version: 4.5.2
Coin version: 3.1.0
SoQt version: 1.4.1
OCC version: 6.5.1
Tagsconstraints, dragging

Relationships

related to 0000754 assignedabdullah GCS Sketcher doesn't report that a fully constrained sketch may have multiple (finite) solutions 

Activities

miscjunk

2014-09-05 12:30

reporter  

drag_problem.FCStd (3,473 bytes)

bejant

2014-09-05 14:47

reporter   ~0005076

Last edited: 2014-09-05 14:48

View 2 revisions

This ticket may be a duplicate of ticket 0000754

Relevant forum thread for this ticket:
http://forum.freecadweb.org/viewtopic.php?f=3&t=7589

wmayer

2016-10-21 15:08

administrator  

0001734.png (30,838 bytes)
0001734.png (30,838 bytes)

wmayer

2016-10-21 15:20

administrator   ~0007412

Still happens with 0.17. When releasing the dragged point after moving a quarter of the circle and then dragging again the jumping doesn't occur. However, it again happens after moving the next quarter of the circle. Looks like there is flip of the sign of the solution.

Kunda1

2017-10-19 11:43

administrator   ~0010330

Is this ticket in fact a dupe of 0000754 ?

Kunda1

2017-12-09 17:19

administrator   ~0010559

Requesting feedback on a way forward with this bug: https://forum.freecadweb.org/viewtopic.php?p=203580#p203580

abdullah

2017-12-11 15:38

manager   ~0010566

https://github.com/FreeCAD/FreeCAD/pull/1157

wmayer

2017-12-12 21:47

administrator   ~0010594

https://github.com/FreeCAD/FreeCAD/commit/eff8529ec6ca4a530740b2a03322679804ff070d

Issue History

Date Modified Username Field Change
2014-09-05 12:30 miscjunk New Issue
2014-09-05 12:30 miscjunk File Added: drag_problem.FCStd
2014-09-05 14:47 bejant Note Added: 0005076
2014-09-05 14:48 bejant Note Edited: 0005076 View Revisions
2016-10-21 15:08 wmayer File Added: 0001734.png
2016-10-21 15:20 wmayer Note Added: 0007412
2016-10-21 15:20 wmayer Status new => confirmed
2017-09-27 12:31 Kunda1 Tag Attached: constraints
2017-09-27 12:32 Kunda1 Relationship added related to 0000754
2017-10-19 11:43 Kunda1 Note Added: 0010330
2017-12-09 17:19 Kunda1 Note Added: 0010559
2017-12-10 21:01 Kunda1 Tag Attached: dragging
2017-12-10 21:01 Kunda1 Target Version => 0.17
2017-12-10 21:05 Kunda1 Assigned To => abdullah
2017-12-10 21:05 Kunda1 Status confirmed => assigned
2017-12-11 15:38 abdullah Note Added: 0010566
2017-12-12 21:47 wmayer Status assigned => closed
2017-12-12 21:47 wmayer Resolution open => fixed
2017-12-12 21:47 wmayer Fixed in Version => 0.17
2017-12-12 21:47 wmayer Note Added: 0010594