View Issue Details

IDProjectCategoryView StatusLast Update
0001717SketcherBugpublic2015-02-25 10:20
ReporterDeepSOICAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSWindowsOS Version8.1 64bit
Product Version0.14 
Target VersionFixed in Version0.15 
Summary0001717: It is hard to move lines with digitizer pen. It is impossible to move points.
DescriptionWhen using digitizer pen instead of a mouse, it is very hard to move lines in sketcher. I have to initiate the move precisely along the line to grab it.
It is almost completely impossible to move points with digitizer pen, presumably because there is no way to drag along a point. I can manage to drag a point if I initiate the move slightly outside of the point and go through it (and only if I'm lucky, works once in 0000023:0000020 attempts).
Steps To ReproduceA digitizer tablet with an active pen is required.
1. create a new document
2. create a new sketch. Draw an arbitrary line on it.
3. Move the line by tapping and dragging with pen. The line is moved only if the drag is initiated strictly along the line, otherwise the line remains in place.
4. Move one of the line's ends by tapping and dragging it with pen. The point should follow the pen, but it stays in place.
Additional InformationThe problem is with pen input. Same holds true when using touchscreen by finger, except that it's hard to hit the thin line. Moving stuff using conventional mouse works good.

I think this is related to how Windows filters pen input before sending it to the application. Here is what Windows does:

When I press on the pen, Windows does not send a mousedown message immediately. This is because Windows has to figure out whether I want to tap-and-drag or tap-and-hold (the first action simulates a drag with left mouse button, while the second simulates a left mouse button click). As soon as Windows figures out that I tap-and-drag (i.e. the pen had traveled >0000009:0000010 pixels before tap-and-hold delay ended), it sends mousedown and subsequent mousemove messages in very quick succession.

I suspect that FreeCAD ignores mousedown completely: the first mousemove with a (simulated) right-mouse-button pressed falls well outside of the point/line being dragged.

The bug can actually be reproduced with a regular mouse:
1. aim the cursor onto a point,
2. press left mouse button and hold it,
3. very abruptly (with high acceleration) move the mouse.
The point remains in place instead of following the cursor.

I am experiencing the same issue with Inkscape, BTW. The move must travel first few pixels without leaving the object being dragged.

I can make a video if required.
Related forum thread: http://forum.freecadweb.org/viewtopic.php?f=8&t=7501
TagsGUI

Relationships

related to 0001149 closedshoogen FreeCAD Imposible to use wacom tablet 

Activities

DeepSOIC

2014-08-30 00:16

developer   ~0005023

Oops! Mantis has converted my approximate numbers prefixed by tildes into some irrelevant links =)
Those numbers were "approx. 20 attemps" and "approx. 10 pixels".

bejant

2014-09-01 16:00

reporter   ~0005053

Last edited: 2014-09-02 18:54

View 2 revisions

==========
  "The bug can actually be reproduced with a regular mouse:
  1. aim the cursor onto a point,
  2. press left mouse button and hold it,
  3. very abruptly (with high acceleration) move the mouse.
  The point remains in place instead of following the cursor."
==========
I was able to reproduce this problem. Moving the cursor slowly or even at a medium speed after selecting the point allows the point to move. If the cursor is moved in quick manner after selecting the point, the point does not move. Keeping the LMB pressed after selecting the point, then waiting a while before rapidly moving the mouse makes no difference.

OS: Windows XP
Word size: 32-bit
Version: 0.14.3700 (Git)
Branch: releases/FreeCAD-0-14
Hash: 32f5aae0a64333ec8d5d160dbc46e690510c8fe1
Python version: 2.6.2
Qt version: 4.5.2
Coin version: 3.1.0
SoQt version: 1.4.1
OCC version: 6.5.1

wmayer

2014-09-03 13:00

administrator   ~0005061

With 0.14.3700 I can confirm this behaviour. However, with the current master branch this issue seems to be fixed. Can anyone else confirm this?

I guess this fixed it: https://github.com/FreeCAD/FreeCAD_sf_master/commit/6eeaae57b8c6898a5c1514b126c290197382a381

DeepSOIC

2014-09-08 20:49

developer   ~0005080

Finally, I ... eem ... WE have built FreeCAD on my PC. And I confirm that the bug is fixed. Lines and points in sketcher move beautifully with a pen! And with touch as well (provided I hit the line/point). Feel free to close the bug.

Related Changesets

FreeCAD: master 6eeaae57

2014-08-23 03:58:04

nahshon


Committer: wmayer Details Diff
Sketcher: Ignore small mouse moves after selection.
Switch to drag mode only after cursor moved 3 pixels.
Affected Issues
0001717
mod - src/Mod/Sketcher/Gui/ViewProviderSketch.cpp Diff File

Issue History

Date Modified Username Field Change
2014-08-30 00:06 DeepSOIC New Issue
2014-08-30 00:16 DeepSOIC Note Added: 0005023
2014-09-01 16:00 bejant Note Added: 0005053
2014-09-02 18:54 bejant Note Edited: 0005053 View Revisions
2014-09-02 19:10 shoogen Tag Attached: GUI
2014-09-03 13:00 wmayer Note Added: 0005061
2014-09-08 20:49 DeepSOIC Note Added: 0005080
2014-09-09 08:14 shoogen Status new => closed
2014-09-09 08:14 shoogen Resolution open => fixed
2014-09-09 08:14 shoogen Fixed in Version => 0.15
2014-09-09 13:15 wmayer Changeset attached => FreeCAD Master master 6eeaae57
2015-02-25 10:20 shoogen Relationship added related to 0001149