View Issue Details

IDProjectCategoryView StatusLast Update
0000171FreeCADBugpublic2010-12-15 11:55
Reporteryorik Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.11 
Summary0000171: Unify Draft keyboard shortcuts
DescriptionThe draft module uses a lot of hardcoded shortcuts, that should either depend on the localization (using "&" in the texts) or be customizable via the freecad customize screen
TagsNo tags attached.

Activities

yorik

2010-12-15 11:55

administrator   ~0000453

This is now basically done, all actions in the Draft module that are not FreeCAD commands but anyway would need a keyboard shortcut now have 3 levels of customization:
- a builtin "hard-coded" shortcut
- an ALT-shortcut defined in the widget label, that can be changed by translators
- a proper FreeCAD shortcut, defined by the FreeCAD customize menu.

I didn't totally remove the hardcoded shortcuts, because some qt widgets really steal all keypresses without modifier key, but I think with two alternatives this is not too bad.

Issue History

Date Modified Username Field Change
2010-10-08 13:03 yorik New Issue
2010-10-08 13:03 yorik Status new => assigned
2010-10-08 13:03 yorik Assigned To => yorik
2010-12-15 11:55 yorik Note Added: 0000453
2010-12-15 11:55 yorik Status assigned => closed
2010-12-15 11:55 yorik Resolution open => fixed
2010-12-15 11:55 yorik Fixed in Version => 0.11