View Issue Details

IDProjectCategoryView StatusLast Update
0000017FreeCADFeaturepublic2017-09-14 13:46
ReporterJriegelAssigned ToJriegel 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.17 
Summary0000017: Support of more basic elements
DescriptionI think, it would be good to support more basis elements, and basis
functionalities which are usefull for more than one application.

Elements:
- axis systems (interesting for CAM, Measuring, ...)
- point and plane (cutting, ...)

Functionality:
- (show/noshow) show all invisible elements, an select the elements to
change them to visible

- (selection of elements) by fence, by box, ...

I think, some of these functions should appear in the basic system, to be
used from every application.
TagsNo tags attached.

Relationships

duplicate of 0000328 closed Support of more basic elements 

Activities

Jriegel

2010-06-29 13:59

administrator   ~0000255

I think I will at least do the plane and coordinate system

yorik

2010-07-02 17:34

administrator   ~0000258

Would be cool... Take a look at the Draft's working plane that Ken Cline made, I found it pretty cool to use. Doesn't bother you when you don't need it, but it's there when you need...

Basically it is just a plane, that has axis, u and v vectors (local x,y,z) and a position. You can define it anytime, or "release" it. If it is defined, everything you do (draw, transform, etc) "sticks" to it, otherwise not. Pretty easy.

Select by box would be pretty useful too...

wmayer

2010-08-18 10:08

administrator   ~0000300

Original link: https://sourceforge.net/tracker/?func=detail&aid=1818040&group_id=49159&atid=455301

Jriegel

2011-01-13 14:59

administrator   ~0000514

I fear have to wait for 0.12

Issue History

Date Modified Username Field Change
2009-09-28 15:41 Jriegel New Issue
2009-09-28 15:48 Jriegel Status new => assigned
2009-09-28 15:48 Jriegel Assigned To => Jriegel
2010-06-29 13:59 Jriegel Note Added: 0000255
2010-06-29 13:59 Jriegel Target Version => 0.11
2010-06-29 13:59 Jriegel Description Updated
2010-07-02 17:34 yorik Note Added: 0000258
2010-08-18 10:08 wmayer Note Added: 0000300
2011-01-13 14:59 Jriegel Note Added: 0000514
2011-01-13 14:59 Jriegel Target Version 0.11 => 0.12
2011-01-13 14:59 Jriegel Description Updated
2011-09-16 04:59 Jriegel Target Version 0.12 => 0.13
2012-02-29 11:04 wmayer Relationship added duplicate of 0000328
2012-11-13 20:25 Jriegel Target Version 0.13 => 0.14
2014-06-25 12:08 wmayer Target Version 0.14 => 0.15
2015-01-25 15:43 yorik Target Version 0.15 =>
2017-09-14 13:46 wmayer Status assigned => closed
2017-09-14 13:46 wmayer Resolution open => fixed
2017-09-14 13:46 wmayer Fixed in Version => 0.17