View Issue Details

IDProjectCategoryView StatusLast Update
0001674FreeCADFeaturepublic2016-05-06 17:05
Reportermghansen256Assigned Towmayer 
PrioritylowSeveritytweakReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSKubuntuOS Version14.04
Product Version0.14 
Target VersionFixed in Version0.17 
Summary0001674: Allow clearing keyboard shortcuts for actions
DescriptionSituation is related to but 1673: I want to re-assign the shortcut ctrl-d. But before I can assign it to "Edit->Duplicate", I have to assign another shortcut to "Appearance". I have to give "Appearance" an unused shortcut that, because I can not clear the one which is already set. It would be nice if I could simply clear a shortcut instead of having to assign a new one.
Additional InformationOS: Ubuntu 14.04.1 LTS
Word size: 64-bit
Version: 0.15.3844 (Git)
Branch: master
Hash: 28490532f50135e2490f94cdf401b613a94b1ec2
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
SoQt version: 1.6.0a
OCC version: 6.7.0
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

FreeCAD: master 237bf833

2016-05-06 19:04:26

wmayer

Details Diff
+ fixes 0001674: Allow clearing keyboard shortcuts for actions Affected Issues
0001674
mod - src/Gui/DlgKeyboard.ui Diff File
mod - src/Gui/DlgKeyboardImp.cpp Diff File
mod - src/Gui/DlgKeyboardImp.h Diff File

Issue History

Date Modified Username Field Change
2014-08-08 18:39 mghansen256 New Issue
2016-05-06 17:04 wmayer Changeset attached => FreeCAD Master master 237bf833
2016-05-06 17:04 wmayer Assigned To => wmayer
2016-05-06 17:04 wmayer Status new => closed
2016-05-06 17:04 wmayer Resolution open => fixed
2016-05-06 17:05 wmayer Fixed in Version => 0.17