View Issue Details

IDProjectCategoryView StatusLast Update
0001672Raytracing[FreeCAD] Bugpublic2018-09-22 08:49
ReportertriplusAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version14.04
Product Version 
Target VersionFixed in Version[FreeCAD] 0.18 
Summary0001672: Raytracing export to POV-Ray - respect ASCII convention for I/O filenames
DescriptionSeeing FreeCAD is now complying with POV-Ray strict object identifiers naming convention: 0001663

There is one more thing preventing FreeCAD end users to expect 100% success rate when everything is setup correctly. POV-Ray has quite strict I/O filename naming convention. For example no empty spaces or umlauts are allowed in I/O filename/path ATM. We can only imagine how big impact this has on success rate where user defines filename with empty space in it or for example tries to save the image to a folder with non-ASCII character in its name...

http://news.povray.org/povray.bugreports/thread/%3Cweb.496fb786bf462a2269c743b90@news.povray.org%3E/

I thought about how this could be solved (for FreeCAD POV-RAY users) and will list 3 possible solutions:

1.) File save dialogue would not allow non-ASCII characters in output filename/path. While this could work if implemented i doubt users of FreeCAD would be happy with this in the long run.

2.) Give the users what they want (utf8) by leveraging FreeCAD capabilities. Long story short currently POV-Ray takes care of saving the output file by FreeCAD making subprocess.call to POV-Ray executable where +O directive is added and user defined output filename/path from GUI dialogue is attached to +O directive!

I propose adding 2 more steps to the process compared to current solution:

Step one:
If possible +O directive would be replaced with temporary ASCII filename that would be saved to temporary location.

Step two:
FreeCAD takes care of moving/copying temporary made image file to user defined location (from the GUI dialogue).

3.) If solution 2 is not possible render the image directly to (ASCII filename) temporary location and open it in Image Workbench. If this is currently possible user probably should be notified produced image is not saved before closing FreeCAD and it should be done manually before closing FreeCAD if users would like to permanently store the image.
TagsRaytracing, unicode

Relationships

related to 0002908 closedwmayer FreeCAD stp file import name mismatch (due to some limitation into UTF-8 support & naming convention) 
related to 0002973 confirmed FreeCAD Path to FreeCAD.app can't contain unicode 
related to 0003521 closedwmayer Expressions Import of csv file into Spreadsheet does not work if the path contains non ASCII characters 

Activities

Kunda1

2017-06-10 04:34

manager   ~0009324

@triplus is this still reproducible ?

Kunda1

2018-09-14 12:01

manager   ~0011735

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=30929

wmayer

2018-09-22 08:49

administrator   ~0011804

https://github.com/FreeCAD/FreeCAD/commit/f6b4ffb14904dbd9519152664c691a0d962c3cc6

Issue History

Date Modified Username Field Change
2014-08-08 17:24 triplus New Issue
2017-02-02 01:29 Kunda1 Description Updated View Revisions
2017-02-02 01:29 Kunda1 Tag Attached: Raytracing
2017-06-10 04:34 Kunda1 Note Added: 0009324
2017-12-18 01:17 Kunda1 Project FreeCAD => Raytracing
2018-07-03 02:28 Kunda1 Tag Attached: unicode
2018-07-03 02:28 Kunda1 Relationship added related to 0002908
2018-07-03 02:29 Kunda1 Relationship added related to 0002973
2018-07-03 02:30 Kunda1 Relationship added related to 0003521
2018-09-14 12:01 Kunda1 Note Added: 0011735
2018-09-22 08:49 wmayer Assigned To => wmayer
2018-09-22 08:49 wmayer Status new => closed
2018-09-22 08:49 wmayer Resolution open => fixed
2018-09-22 08:49 wmayer Fixed in Version => 0.18
2018-09-22 08:49 wmayer Note Added: 0011804