View Issue Details

IDProjectCategoryView StatusLast Update
0001663FreeCADBugpublic2014-08-08 01:52
ReportergeniiAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSKubuntu 14.04.1OS Version
Product Version0.14 
Target VersionFixed in Version 
Summary0001663: Raytracing export to POVRay file syntax issue
DescriptionThis is with nightly git
Default part names like Part1 (Solid) are not changed to something POVRay can parse.It complains "expected '=' but found '(' "
Steps To ReproduceConvert a part to a solid and export that to POV file.
Attempt to render on commandline with POVRay.
TagsNo tags attached.

Activities

triplus

2014-08-03 21:36

developer   ~0004917

I just wanted to open similar bug report for situations when empty spaces are exported from FreeCAD object label into POV-Ray object identifier producing Parse Error instead of rendered image and i will complement this bug report with additional information.

POV-Ray is quite strict when defining (object) identifiers:

-1 to 40 characters long
-upper and lower case letters
-digits 0 through 9
-underscore character is allowed
-first character must be an alphabetic character.

I was thinking first step could be to remove empty spaces and replace them with underscore character. Empty space in FreeCAD object Label is quite common and we can only imagine how low success rate we have when users pressing the render button. Anyway after thinking about this further i do believe more general solution must be provided to get high success rate when user presses render button in FreeCAD.

Two thought:

1.) Use FreeCAD internal object name instead of (user defined) object Label. I guess this could cover most scenarios but i am not sure about all objects in FreeCAD (current and future) how they comply with POV-Ray rules.

2.) Export FreeCAD object into POV-Ray identifier and replace FreeCAD object label/name with for example:

fc_object_1
fc_object_2
...
fc_object_1000...

Second solution would probably always work as expected. In both cases it will be harder to find corresponding object when manually editing .pov file but on the bright side as said render button will probably always work.

yorik

2014-08-08 01:11

administrator   ~0004925

Last edited: 2014-08-08 01:22

View 2 revisions

Hm it seems to be the same problem indeed. Surely solution 1 is better... Looks simple to fix (FreeCAD internal names already comply to these rules)

Related Changesets

FreeCAD: master 6b5b1a74

2014-08-08 03:24:57

yorik

Details Diff
Raytracing: Using names instead of labels in exported files - fixes 0001663 Affected Issues
0001663
mod - src/Mod/Raytracing/App/LuxFeature.cpp Diff File
mod - src/Mod/Raytracing/App/RayFeature.cpp Diff File

Issue History

Date Modified Username Field Change
2014-08-02 18:20 genii New Issue
2014-08-03 21:36 triplus Note Added: 0004917
2014-08-08 01:11 yorik Note Added: 0004925
2014-08-08 01:11 yorik Assigned To => yorik
2014-08-08 01:11 yorik Status new => assigned
2014-08-08 01:22 yorik Note Edited: 0004925 View Revisions
2014-08-08 01:52 yorik Changeset attached => FreeCAD Master master 6b5b1a74
2014-08-08 01:52 yorik Status assigned => closed
2014-08-08 01:52 yorik Resolution open => fixed