View Issue Details

IDProjectCategoryView StatusLast Update
0000166FreeCADBugpublic2011-01-26 12:10
ReporteryorikAssigned ToJriegel 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.11 
Summary0000166: edges highlight doesn't work anymore
DescriptionI'm not sure if it's the case for everyone, it could be only on my system, but it seems that edge highlighting doesn't work anymore? (Highlighting is turned on, face highlight works OK)
Can anyone else check?
TagsNo tags attached.

Activities

wmayer

2010-10-11 14:59

administrator   ~0000363

Yes, I also noticed this behaviour some time ago. If you choose another line color than black then it seems to work.

unauthenticated

2010-10-11 17:19

viewer   ~0000364

Last edited: 2010-10-11 17:20

Indeed you're right... The highlight mechanisms works, but it doesn't respect the colors specified in the preferences, it highlights all edges in black, so if you draw in black you just don't see it.
The texts and faces are highlighted with the correct color, though.
yorik

wmayer

2010-10-12 11:31

administrator   ~0000372

Apparently the issue is partially related to the platform. On 32-bit at least the selection works as expected but not on 64-bit. And the pre-selection doesn't work on any of the platforms.

This all is also related to the front buffer we use. If it is disabled everything works normally.

Jriegel

2011-01-13 08:34

administrator   ~0000509

I changed the preselection color. On Windows release works fine...
Hope the color change makes it better on other platforms.

Otherwise I run out of ideas. Think the next step is a complete
rebuild of the selection. But at the moment I have no time for that....

Jriegel

2011-01-26 12:10

administrator   ~0000554

Werner changed the defaults for the 64 bit platform.

This at least works - but, as I said, selection need
an overhaul....

Issue History

Date Modified Username Field Change
2010-10-08 00:47 yorik New Issue
2010-10-11 14:59 wmayer Note Added: 0000363
2010-10-11 17:19 unauthenticated Note Added: 0000364
2010-10-11 17:20 unauthenticated Note Edited: 0000364
2010-10-12 09:33 wmayer Assigned To => Jriegel
2010-10-12 09:33 wmayer Status new => assigned
2010-10-12 11:31 wmayer Note Added: 0000372
2011-01-13 08:34 Jriegel Note Added: 0000509
2011-01-13 08:34 Jriegel Status assigned => feedback
2011-01-26 12:10 Jriegel Note Added: 0000554
2011-01-26 12:10 Jriegel Status feedback => closed
2011-01-26 12:10 Jriegel Resolution open => fixed
2011-01-26 12:10 Jriegel Fixed in Version => 0.11