View Issue Details

IDProjectCategoryView StatusLast Update
0001633SketcherFeaturepublic2014-07-27 09:18
Reportermghansen256Assigned Towmayer 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.14 
Target VersionFixed in Version0.15 
Summary0001633: Allow adding radius constraints to several circles at once.
DescriptionSituation: I have four circles to which I want to assign the same radius. When I select more than one circle, the radius constraint complains that I may only select one.

If rejected, it would be nice to disable the radius constraint when I select more than one circle, to know that it is unavailable.
TagsNo tags attached.

Activities

wmayer

2014-07-23 21:53

administrator   ~0004844

You can also just set the radius for the first circle. Then select all four circles and use the equality constraint. This way the other three circles always have the same radius as the reference circle.

If you later change the radius of the reference circle the radii of the others will update automatically.

normandc

2014-07-24 14:38

manager   ~0004845

Last edited: 2014-07-24 14:40

View 2 revisions

The original request is an uninformed (and BAD) use of constraints. As wmayer wrote the proper way to constrain multiple circles to the same radius is to affect them all an equality constraint, then apply a radial constraint on a single one.

I'm afraid the feature as it was implemented will actually encourage bad practice. I guess we will see.

wmayer

2014-07-24 16:20

administrator   ~0004847

But the OP is right in one point (even though he doesn't mention it explicitly): you have to make a lot of clicks for no obvious reason.

Example:
You have 20 arcs or circles for which you want to set the same radius. Someone who does it the first time may select all of them and then he gets an error dialog that this can be done for a single item only. So, he de-selects everything and either does it for each item individually (a) or knows about the equality constraint and uses that (b).

(a) is a very slow way because you have to select the item, enter a new value and confirm it => more than 60 clicks and a lot of typing
(b) is much faster but still slower as it could be => more than 40 clicks

With the new approach you only have to select the items once, enter one value and confirm it => 21 clicks and typing stuff only once.

Besides this, the old approach checked for other items than arc and circle and reported an error. The new approach silently filters them out and processes only the valid items. Only in case the user has selected everything but arc or circle an error message comes up. So, now it's even possible to use the rubberband selection so that at the end you have to make around three clicks and you are done.

@Norm: your concern apparently is about that users now set independent radii for the arcs and circles and if they later want to change them they have to do this individually. To avoid this we could in case of multi-selection pop up a dialog and ask the user to set independent radii or use the equality constraint.

Related Changesets

FreeCAD: master 996af8d8

2014-07-24 13:32:47

wmayer

Details Diff
+ fixes 0001633: Allow adding radius constraints to several circles at once. Affected Issues
0001633
mod - src/Mod/Sketcher/Gui/CommandConstraints.cpp Diff File

Issue History

Date Modified Username Field Change
2014-07-23 19:37 mghansen256 New Issue
2014-07-23 21:53 wmayer Note Added: 0004844
2014-07-24 12:02 wmayer Changeset attached => FreeCAD Master master 996af8d8
2014-07-24 12:02 wmayer Assigned To => wmayer
2014-07-24 12:02 wmayer Status new => closed
2014-07-24 12:02 wmayer Resolution open => fixed
2014-07-24 14:38 normandc Note Added: 0004845
2014-07-24 14:38 normandc Status closed => feedback
2014-07-24 14:38 normandc Resolution fixed => reopened
2014-07-24 14:40 normandc Note Edited: 0004845 View Revisions
2014-07-24 14:41 normandc Status feedback => resolved
2014-07-24 16:20 wmayer Note Added: 0004847
2014-07-27 09:18 wmayer Status resolved => closed
2014-07-27 09:18 wmayer Resolution reopened => fixed
2014-07-27 09:18 wmayer Fixed in Version => 0.15