View Issue Details

IDProjectCategoryView StatusLast Update
0001632SketcherFeaturepublic2018-08-26 18:38
Reportermghansen256Assigned Toabdullah 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.14 
Target VersionFixed in Version0.18 
Summary0001632: Allow entering of diameter instead of radius for circle radius constraint.
DescriptionWhen adding a radius constraint to a circle, it would be useful to be able to switch to entering the diameter instead of the radius, when the documentation from which I generate the constraints only provides diameters. No more division by 2 in my head ;-)

One could simply add a drop-down "radius","diameter" to the dialog box asking for the radius.
TagsNo tags attached.

Relationships

has duplicate 0002317 closed FreeCAD diameter vs radius 

Activities

wmayer

2014-07-23 21:19

administrator   ~0004842

Given that you have to enter an odd value as diameter e.g. "22.126 mm" then the workaround is to write "22.126/2 mm" instead.

Additionally the diameter constraint can be supported, too. This however will be a new constraint type with is own symbol in the 3d view. Just replacing the current radius input with a diameter input and doing the division by 2 internally might be confusing because in the 3d view something different is shown that the user may not expect.

ngallaher

2014-07-25 17:27

reporter   ~0004858

I'd like to implement this. I'll try to get a patch submitted in the next day or two.

Kunda1

2017-02-09 21:15

administrator   ~0008255

@ngallaher ping
Still interested in making a patch?

Kunda1

2018-06-06 16:51

administrator   ~0011357

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=29152

abdullah

2018-06-15 14:32

manager   ~0011439

PR:
https://github.com/FreeCAD/FreeCAD/pull/1520

wmayer

2018-07-30 10:31

administrator   ~0011565

https://github.com/FreeCAD/FreeCAD/commit/c84fe5fa3db1bf3758668809bb7c55557e3562a4

Issue History

Date Modified Username Field Change
2014-07-23 19:33 mghansen256 New Issue
2014-07-23 21:19 wmayer Note Added: 0004842
2014-07-25 17:27 ngallaher Note Added: 0004858
2015-10-31 12:43 wmayer Relationship added has duplicate 0002317
2017-02-09 21:15 Kunda1 Note Added: 0008255
2017-02-09 21:16 Kunda1 Tag Attached: #lowhangingfruit
2018-06-06 16:51 Kunda1 Note Added: 0011357
2018-06-15 14:32 abdullah Assigned To => abdullah
2018-06-15 14:32 abdullah Status new => assigned
2018-06-15 14:32 abdullah Note Added: 0011439
2018-07-30 10:31 wmayer Status assigned => closed
2018-07-30 10:31 wmayer Resolution open => fixed
2018-07-30 10:31 wmayer Fixed in Version => 0.18
2018-07-30 10:31 wmayer Note Added: 0011565
2018-08-26 18:38 Kunda1 Tag Detached: #lowhangingfruit