View Issue Details

IDProjectCategoryView StatusLast Update
0001623SketcherFeaturepublic2014-09-28 10:40
Reporterbejant Assigned Toabdullah  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.14 
Target VersionFixed in Version0.15 
Summary0001623: Sketcher - Always Display Symmetry Constraint Symbol Perpendicular to Axis of Symmetry
DescriptionWhen it is used, the Symmetry Constraint symbol always is aligned horizontally, even when the axis of symmetry is skewed or horizontal. This can be confusing when the axis of symmetry is angled, the axis of symmetry is horizontal, or the view is rotated, especially in complicated Sketches.

It would be more helpful and meaningful if the Symmetry Constraint symbol was displayed so that its "arrows" always point perpendicularly towards the axis of symmetry, even as the view is rotated. The Horizontal and Vertical Distance Constraint symbols always remain aligned with the line they constrain, even when the view is rotated, and I am asking that the Symmetry Constraint symbol be enhanced in a similar manner.

   
Steps To ReproduceSee attached image:
1. Create a Sketch in the X-Y Plane.
2. Draw a line segment parallel with the Y-axis, straddling the X-axis.
3. Apply the Symmetry Constraint between the endpoints and the Z-axis.
4. Apply a Vertical Distance Constraint to the line segment.

The arrowheads of the Symmetry Constraint appear horizontally, which is misleading to the user.

5. Rotate the view about the Z-axis.

The Vertical Distance Constraint rotates with the view but the Symmetry Constraint Symbol remains oriented incorrectly (horizontally).
Additional InformationForum topic:
http://forum.freecadweb.org/viewtopic.php?f=19&t=6875

OS: Ubuntu 12.04.4 LTS
Word size: 32-bit
Version: 0.15.3744 (Git)
Branch: master
Hash: eea27448e995bc87eedaffc3f9153a75291bf9f4
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.7.0
TagsNo tags attached.
FreeCAD Information

Activities

bejant

2014-07-20 17:47

reporter  

20140720a_Mantis.png (5,062 bytes)
20140720a_Mantis.png (5,062 bytes)

abdullah

2014-09-18 13:35

manager   ~0005123

Fixed in current master as of today (will appear in the PPA tomorrow)

shoogen

2014-09-27 08:55

developer   ~0005156

A crash bug seems to be related
http://forum.freecadweb.org/viewtopic.php?f=3&t=7820

abdullah

2014-09-27 15:19

manager   ~0005157

Sebastian, I have just seen this. Which is the status of this? Shall I close this or there is some further action to take...

abdullah

2014-09-28 04:56

manager   ~0005162

I assume that with the fix of Werner for handling the zero division exception, everything works just fine.

Related Changesets

FreeCAD: master 95c512d9

2014-08-23 06:30:48

abdullah


Committer: wmayer Details Diff
Sketcher feature enhancement: Symmetry constraint perpendicular to axis of symmetry

Solves Mantis ticket: http://www.freecadweb.org/tracker/view.php?id=1623
Unrelated minor fix: remove unused variable
Affected Issues
0001623
mod - src/Mod/Sketcher/Gui/ViewProviderSketch.cpp Diff File
mod - src/Mod/Sketcher/Gui/ViewProviderSketch.h Diff File

FreeCAD: master f0bf3cb6

2014-09-27 15:53:21

wmayer

Details Diff
+ Proper handling of sketch plane parallel to view direction Affected Issues
0001623
mod - src/Base/Exception.cpp Diff File
mod - src/Base/Exception.h Diff File
mod - src/Mod/Sketcher/Gui/ViewProviderSketch.cpp Diff File

Issue History

Date Modified Username Field Change
2014-07-20 17:47 bejant New Issue
2014-07-20 17:47 bejant File Added: 20140720a_Mantis.png
2014-09-02 13:50 abdullah Assigned To => abdullah
2014-09-02 13:50 abdullah Status new => assigned
2014-09-18 13:35 abdullah Note Added: 0005123
2014-09-18 13:35 abdullah Status assigned => resolved
2014-09-18 13:35 abdullah Fixed in Version => 0.15
2014-09-18 13:35 abdullah Resolution open => fixed
2014-09-18 16:50 wmayer Status resolved => closed
2014-09-27 08:55 shoogen Note Added: 0005156
2014-09-27 08:55 shoogen Status closed => feedback
2014-09-27 08:55 shoogen Resolution fixed => reopened
2014-09-27 15:19 abdullah Note Added: 0005157
2014-09-28 04:56 abdullah Note Added: 0005162
2014-09-28 04:56 abdullah Status feedback => resolved
2014-09-28 04:56 abdullah Resolution reopened => fixed
2014-09-28 10:31 wmayer Changeset attached => FreeCAD Master master f0bf3cb6
2014-09-28 10:35 wmayer Changeset attached => FreeCAD Master master 95c512d9
2014-09-28 10:40 wmayer Status resolved => closed